Email Purchase Order doesn't seem to work - urgent

Hi,

Apologies if this has already been asked previously.

As an administrator, I can click on Email link from a Purchase Order and sent an email to a valid email address. I can confirm that the email is being sent and received at the other end. But when I login as any other user who is not a administrator, system doesn’t seem to send any email. I can see a pop-up message ‘Email Sent <name of recipient>’ but the actual email is not being sent.

Is there any permission I need to enable for this to work for other users.

I will appreciate a quick response as it is urgent. Thanks in advance.

Kind regards,
Mayur Patel



Note:

 

If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.

     

    End of Note



    You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

    To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un...@googlegroups.com.

    For more options, visit https://groups.google.com/groups/opt_out.

     

     
Hi Mayur,

It could be due to a setting in your SMTP server. It might not be configured to handle different senders. 

If you get "Email Sent", it means that the SMTP server didn't throw any exception and has accepted the message for delivery.

Which SMTP server/relay are you using?

Thanks,
Anand.

On 16-Jul-2013, at 4:32 PM, MP <ma...@gmail.com> wrote:

Hi,

Apologies if this has already been asked previously.

As an administrator, I can click on Email link from a Purchase Order and sent an email to a valid email address. I can confirm that the email is being sent and received at the other end. But when I login as any other user who is not a administrator, system doesn't seem to send any email. I can see a pop-up message 'Email Sent <name of recipient>' but the actual email is not being sent.

Is there any permission I need to enable for this to work for other users.

I will appreciate a quick response as it is urgent. Thanks in advance.

Kind regards,
Mayur Patel



Note:

 

If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.

     

    End of Note



    You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

    To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un…@googlegroups.com.

    For more options, visit https://groups.google.com/groups/opt_out.

     

     



Note:

 

If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.

     

    End of Note



    You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

    To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un...@googlegroups.com.

    For more options, visit https://groups.google.com/groups/opt_out.

     

     

Thanks Anand for your prompt response.

For security reason, I will send you an email on su...@erpnext.com about this.

Kind regards,
Mayur Patel

On Tuesday, July 16, 2013 12:07:09 PM UTC+1, Anand Doshi wrote:

Hi Mayur,

It could be due to a setting in your SMTP server. It might not be configured to handle different senders. 

If you get “Email Sent”, it means that the SMTP server didn’t throw any exception and has accepted the message for delivery.

Which SMTP server/relay are you using?

Thanks,
Anand.

On 16-Jul-2013, at 4:32 PM, MP <ma…@gmail.com> wrote:

Hi,

Apologies if this has already been asked previously.

As an administrator, I can click on Email link from a Purchase Order and sent an email to a valid email address. I can confirm that the email is being sent and received at the other end. But when I login as any other user who is not a administrator, system doesn’t seem to send any email. I can see a pop-up message ‘Email Sent <name of recipient>’ but the actual email is not being sent.

Is there any permission I need to enable for this to work for other users.

I will appreciate a quick response as it is urgent. Thanks in advance.

Kind regards,
Mayur Patel



Note:

 

If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.

     

    End of Note



    You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

    To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un…@googlegroups.com.

    For more options, visit https://groups.google.com/groups/opt_out.

     

     



Note:

 

If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.

     

    End of Note



    You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

    To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un...@googlegroups.com.

    For more options, visit https://groups.google.com/groups/opt_out.