Email inbox error message Invalid Email Account

hello guys!

when i open email inbox from desktop i get an error says Invalid Email Account
i remove my email account and yet i get this error

please advise

Exact same thing is happening to us.

we post errors but no reply for solution any body here expert with erpnext???

I was able to resolve this by checking that the account is working on the ports I selected. Try changing your ports and check if your server allow SMTP connection.

Why not become your own expert https://discuss.erpnext.com/search?q=Invalid%20Email%20Account

I noticed that this also happens if the password to the email account changes. That seems to break th inbox in erpnext. Had to delete the email account in erpnext and recreate it again with the new password.

BKM

Same issue after upgrading v10 to v11. Emails are sent regularly instead, from other forms. I’m unable to check inbound messages, with “invalid email account” message. Tried to delete email account and email domain, but the problem persist

Same here after upgrade

so here after upgrade from 10 to 11 , some users have no problem

We have a similiar problem. Our SMTP is working accordingly, and we have 1 default sending and receiving inbox working fine. Our forget password or welcome email is being sent correctly, but whenever we open the Communication List, this error comes up:

Does anyone know where we should look to fix this? or check where for error logs?

1 Like

@Jonathan_Lee I am also facing the same problem.

Did someone manage to fix it?

ERPNext and Frappe: v11.1.18 (master) on Debian 9

No idea, i’m still having this issue , it seems the error happens to certain account only, some others are fine… not sure what’s the cause.

1 Like

Right now, we only have one account set and it is showing this error.

May be someone from ERPNext team can have a look and verify

Same problem here on v11.
Emails are working but if I try to open communications or email inbox I get multiple Invalid email account

Issue is present in frappe.views.InboxView because frappe.boot.email_accounts.length is set to 0.

Any idea why?

const route = frappe.get_route();
if (!route[3] && frappe.boot.email_accounts.length) {
let email_account;
if (frappe.boot.email_accounts[0].email_id == “All Accounts”) {
email_account = “All Accounts”;
} else {
email_account = frappe.boot.email_accounts[0].email_account;
}
frappe.set_route(“List”, “Communication”, “Inbox”, email_account);
return true;
} else if (!route[3] || (route[3] !== “All Accounts” && !is_valid(route[3]))) {
frappe.msgprint(__(‘Invalid Email Account’));
window.history.back();
return true;
}

With the upgrade to 11.1.25 eveything started to work normally!

same problem here

Before or after you updated to what version?