Easy Install develop fails with ERROR! Unexpected Exception, this is probably a bug: 'module' object has no attribute 'SSL_ST_INIT'

When trying to run the easy install wizard for develop (on a vanilla Debian 8 machine)

$ python install.py --develop

it fails with

ERROR! Unexpected Exception, this is probably a bug: 'module' object has no attribute 'SSL_ST_INIT'
to see the full traceback, use -vvv
Traceback (most recent call last):
  File "install.py", line 417, in <module>
    install_bench(args)
  File "install.py", line 100, in install_bench
    run_playbook('create_user.yml', extra_vars=extra_vars)
  File "install.py", line 338, in run_playbook
    success = subprocess.check_call(args, cwd=os.path.join(cwd, 'playbooks'))
  File "/usr/lib/python2.7/subprocess.py", line 540, in check_call
    raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command '['ansible-playbook', '-c', 'local', 'create_user.yml', '-e', '@/tmp/extra_vars.json']' returned non-zero exit status 250

Note: it affects --production too.

Does anyone else have the same issue?

This seems to resolve it: [Solved] HELP! ERPNext Instance Breaks on Ubuntu 16.04 LTS update

$ pip uninstall pyopenssl
$ pip install pyopenssl

Subsequently, in the install wizard, I observed a “Setup failed: Could not start up: Error in setup”.

grafik

This was caused by an access permission issue, when either all files were owned by frappe or the bench was started with sudo access ($ sudo bench start), it worked…

Try this,

sudo python -m easy_install --upgrade pyOpenSSL

Hope this will solve your problem.