Try ERPNext Buy Support Partners Foundation

Data not saved in web form child table

I have a child table in job application webform when an applicant entering data and save it, data in child table not saving in database

what is the solution here?

Please describe in details,

If possible share the code snippets.

In job applicant doctype I create a child table called Employment History then show it in job applicant web form

now when i create job applicant from webform after that explore job applicant on system found employment history data not saved

but when create job applicant from doctype in system employment history well saved

this pic from web form before click save

this pic after saving but there is no data

Have you done some customisation on web form? some custom triggers on

refresh , onload?

No,

just add fields and child table

can you show us browser consoles or any more details like versions ? so that we can help you more precisely

You can tray Here Click apply now it’s for test

after that, i will show you what i received

I tried it save i guess

1 Like

Yes, and this what i received

this Issue not solved yet

Any update for this issue?

Any one can try student applicant web from it’s have child table

Same Problem.Any Help?

same problem on version 12 with newest update. any help?

Same problem faced on Frappe Framework: v12.4.1 (version-12)

Fixed by @youssef

File: /home/frappe123/frappe-bench/apps/frappe/frappe/public/js/frappe/form/grid.js

Diff in code. Maybe somebody can help push it to core frappe.

							${__("Add Multiple")}</button>
		if (!this.df.data){this.df.data = [];}
		this.data = this.get_data();

		// this.remove_all();
				let d = frappe.model.add_child(this.frm.doc, this.df.options, this.df.fieldname, idx);
				let d = { idx: this.df.data.length + 1, __islocal: true, doctype: this.doctype, parentfield: this.df.fieldname, parenttype: frappe.web_form.doctype }
				this.df.data.push(d);
				if(!frappe.web_form.doc.hasOwnProperty(this.df.fieldname)) {
					frappe.web_form.doc[this.df.fieldname] = [];
				}
				frappe.web_form.doc[this.df.fieldname].push(d);

I used the code from here :wink:

You can continue working to apply this pull request.

I have the same problem. I created a webform for subscription doctype which has a child table called plans. The data I enter in the webform is not getting posted in the database. But I dont face any problem with other web forms which has no child tables.

Still have same issue. can you help?