Creating Report

i have created script report and query report from GUI, but that particular report folder is not created in REPORT folder. Please Any one can help me?..

Check if you have set that report as ‘Standard’ or not

Set that report as a standard report. Also log in Administrator because standard reports can be saved only by Administrator.

@root13F, i have Set ‘Standard’ as yes and i m in Administrator user

Are you sure you are looking in the correct module’s report folder ? Check what is the value there

@root13F, yes i look in correct module.

report1

You want a Query Report or a Script Report ?

In Query report, there will be just a JSON. If you want a Script Report there will be a JS and Python file. If you just want a Query report, try saving it again.

@root13F, i created Both script and query report and i save again, but does not create JSON, JS, and Python file

Can you check site_config.json if you have enabled developer_mode.

1 Like

@vijaywm, i have made developer mode = 1, and even i can create doctype and doctype .js and python file are created. but when i create report, its not created JSON, JS and python file

No ideas… maybe just try creating a new test report, or delete and recreate… can you post the output from dB …tabReport row for this report

DocType “Material Request” Belongs to Stock not Buying, check it in Stock’s report, may be the system created the files and folders there.

1 Like

I found similar issue.

How to debug where it drops the ball? Is there a way to enable logging for a certain call?

developer_mode: 1 is necessary to be integer. I had configured as developer_mode: "1"