Could not install app and migrate after latest release

Dear All,
If someone knows how to solve this issue kindly help me, I am struggling with it from last 10 days.
I was not able to install the an app in newly installed erpnext which show the latest versions of frappe and erpnext.
image

Then I use the the command below

./env/bin/pip  install my-app

and it installed successfully then on migration command it migrates the erpnext and frappe but not my-app

Now after restoring the database when i try to migrate, update .etc it gives a strange error.

Could not found app "None"

Here are are screen shotes of my console:

I shall be very thankfull to you.

If someone want to know the traceback, I have very similar traceback as posted by someone in below link

Hi,
You should run

bench new-app your_app_name
bench install-app your_app_name

from the frappe-bench folder

thanks @NMyshuk I was doing the same before and installed many apps using above command, but now it is not working this way.

maybe you should update your version.
I use

ERPNext: v11.0.3-beta.19 () (staging)
Frappe Framework: v11.0.3-beta.22 () (staging)

and these commands work for me

@NMyshuk
Could you share your operating system vesrion and how do you install the erpnext.

Thanks.

I have Ubuntu 14.04.5 and use manual install https://github.com/frappe/bench

1 Like