Contact duplicity on email sync

Issue: during the mailing sync process (IMAP) any time an email from a sender who is already storaged as “Contact” in the database is found a new contact is created automatically followed by a hyphen and a number.
I’ve seen several threads over here and also posted on GitHub so I would like to know if anyone has already found a solution to avoid this multiplicity.

Browse to the email account settings for the email account in question and uncheck create contacts from incoming email.

It was already unchecked. I’ve also tried to modified the naming section in the Contact doctype and stille haven’t got a clue of where this issue comes from.