Try ERPNext Buy Support Partners Foundation

Company is not showing in V12

This question was raised several time but there is no proper solution.

Here What I did ,

  1. set default company

  2. set permission to user to access one company as below

  1. set user role as sales user which has a company read only access.

  2. log in by that user name and see if I can see the company.

So why the assign user can not see the company?

Any one have encountered same issue?

any solution for this?

Could you please click on the yellow “Restricted” button in the first screenshot and send a screenshot of whatever pops up?

Could you please open the user permission and click on “View Permitted Documents” and check for Company doctype the permissions applied?

nothing showing

Could you check in role permissions manager? Select document type as Company and send a screenshot.

any update for this?

Maybe provide an update what you yourself have found, tried or learned - the idea is to contribute thanks!

This is a real pain

Please share pointers to those, a dialog will benefit all concerned

If any one have same experience?

I got the same issue, Every time I make new VPS.

Probably it is a bug?

The company is not showing because user-permission is also applied on “parent_company” and “existing_company” field inside company record. In your case, mostly those are set as blank. I am assuming in System Settings, you have enabled “Apply Strict User Permissions”, due to which the company is not showing as company is not matching for parent_company and existing_company field.

I have send a fix to ignore user permissions for parent_company and existing_company fields. https://github.com/frappe/erpnext/pull/21010

Until the fixes released, you can enable “Ignore User Permissions” property for those fields from Customize Form -> Company.
Or you can disable strict user permissions from System Settings.

3 Likes

Thank you very much, it worked perfectly with parent companies and all.

1 Like