ERPNext Foundation ERPNext Cloud User Manual Blog Discuss Frappé* Donate

Can't Submit Payroll Entry v 11


#1

Hi All
after upgrading to v11 , i tried to make payroll entry as usal, but submit button is not appearing.
i tried to submit the doc from the list by checking and in action menu i choose submit.
but system say can’t submit.


#2

We had this problem when we switch to v11, it’s not just payroll entry, it’s caused by v11’s new role permission manager separating submit and cancel as a permission.

You need to go to the doctype/role permission manager to grant your role the permission to submit and cancel.


#3

Thanks for reply,
i checked and my role is HR Manager and i found it is granted already to submit.


#4

my role also is system manager and i allowed this role to submit , but still couldn’t submit it.


#5

Did you click “Get Employees” and it managed to retrieve a list of employees matching your payroll entry’s criteria?


#6

Yes it gets the list of employees successfully, and after getting the list the create salary slips blue button appears but nothing happens when pressing and the document is still in draft state


#7

Didn’t get that far for payroll entry, can’t help you here , i think it has some error, you may want to pull out the browser’s Console menu to see what happens when you click the blue button.


#8

@ahmedfme @Ahmed_F_Mostafa

Hi,
This feature is working fine, all you need to do is clear cache after generating draft salary slips. Check the below GIF:

Regards,
Reema


#9

Hi Ahmed, did you find a solution to this problem. I’m struggling with same issue. I have followed every step like yours above over and over but still can’t get the payroll to create payslips