Cannot remove "Name" column from list view (Healthcare)

Hello,

I’m battling with an issue that seems to be a hard-coded feature in ERPNext (Healthcare module). That is, I do not want to use the “Name” (first name) field. I figured out that I cannot delete the field so I made it invisible and added a default value = Name.

The problem is, it still displays in the list view…which I personally find odd because it does not display on each individual record (because it’s hidden right).

I see from this post that the far right column will always be name/UniqueID…but cannot figure out how to change it from Name to something else.

https://discuss.erpnext.com/t/how-to-edit-list-settings/73585/4?

I do not want to (cannot use) the name field for personal information protection reasons. In place of that we are using a unique identifier (ID number). I created a new field for that number but maybe I should have used Name (first_name) instead?? But even then, I don’t want it to display all the way over on the right side (far column)…

Any ideas/advice will be appreciated.

Jason

P.S. I’ve posted a similar inquiry here --> Save button disappears when I try to edit "Patient" doc type in the Healthcare domain?

Solved here --> Save button disappears when I try to edit "Patient" doc type in the Healthcare domain

1 Like