Can not go to desk after run bench update

After I run bench update --patch
I got this error:
Server:
SyntaxError: Unexpected token (18:3487) in /home/frappe/frappe-bench/apps/frappe/node_modules/quill-mention/dist/quill.mention.min.js
Browser:
quill.js:1987 quill Cannot import formats/table-container. Are you sure it was registered?
debug @ quill.js:1987
_import @ quill.js:1044
(anonymous) @ text_editor.js:15
(anonymous) @ multicheck.js:163
text_editor.js:16 Uncaught TypeError: Cannot read property ‘create’ of undefined
at text_editor.js:16
at multicheck.js:163
(anonymous) @ text_editor.js:16
(anonymous) @ multicheck.js:163
assets.js:54 localStorage cleared
assets.js:20 Cleared App Cache.
assets.js:54 localStorage cleared
base_control.js:7 Invalid Control Name: MultiCheck
layout.js:155 Uncaught TypeError: Cannot set property ‘layout’ of undefined
at Dialog.init_field (layout.js:155)
at Dialog.make_field (layout.js:135)
at Object. (layout.js:90)
at Function.each (jquery.min.js:2)
at Dialog.render (layout.js:78)
at Dialog.make (layout.js:24)
at Dialog.make (field_group.js:22)
at Dialog.proto.(anonymous function) [as make] (http://localhost:8000/assets/js/desk.min.js?ver=1540129099.0:65:19)
at Dialog.make (dialog.js:38)
at new Dialog (dialog.js:17)
init_field @ layout.js:155
make_field @ layout.js:135
(anonymous) @ layout.js:90
each @ jquery.min.js:2
render @ layout.js:78
make @ layout.js:24
make @ field_group.js:22
proto.(anonymous function) @ class.js:53
make @ dialog.js:38
Dialog @ dialog.js:17
setup @ modules_select.js:10
ModulesSelect @ modules_select.js:6
setup_modules_dialog @ toolbar.js:34
make @ toolbar.js:25
init @ toolbar.js:18
make_nav_bar @ desk.js:376
startup @ desk.js:44
init @ desk.js:26
frappe.start_app @ desk.js:10
(anonymous) @ desk.js:21
i @ jquery.min.js:2
fireWith @ jquery.min.js:2
ready @ jquery.min.js:2
J @ jquery.min.js:2
quill.js:7647 [Intervention] Slow network is detected. See https://www.chromestatus.com/feature/5636954674692096 for more details. Fallback font will be used while loading: http://localhost:8000/assets/frappe/css/octicons/octicons.woff

I installed project already but it’s not working.

Hi there! any body have the same issue?

Hi @netchampfaris i got this issue and it relate to quill-metio. Please help me.
I use quill-mention 2.04. I just get this issue today

Hmm . I fixed this issue by remove quill-mention 2.0.4 and install quill-mention 2.0.2

@TaiLouis

Hi, can you tell me how you did it? I am still struggling and no solution found here too… it would be really appreciable.

thank you

sorry for late!!
Im using docker.
I go to frappe folder and run: npm uninstall quill-mention and npm install quill-mention@2.0.2
I think the problem here is the new version of quill-mention

2 Likes

I’ve tried uninstalling quill-mention but I get this error. I also tried it by issuing sudo command with no luck. Do you have any idea @TaiLouis ?
turker@turker-fd2:~/frappe-bench2/apps/frappe$ npm uninstall quill-mention
[sudo] password for turker:
npm ERR! prepareGitDep 1>
npm ERR! prepareGitDep > uws@9.14.0 install /home/turker/.npm/_cacache/tmp/git-clone-3d715456/node_modules/uws
npm ERR! prepareGitDep > node-gyp rebuild > build_log.txt 2>&1 || exit 0
npm ERR! prepareGitDep
npm ERR! prepareGitDep
npm ERR! prepareGitDep > wd@1.11.0 install /home/turker/.npm/_cacache/tmp/git-clone-3d715456/node_modules/wd
npm ERR! prepareGitDep > node scripts/build-browser-scripts
npm ERR! prepareGitDep
npm ERR! prepareGitDep
npm ERR! prepareGitDep 2> npm WARN install Usage of the --dev option is deprecated. Use --only=dev instead.
npm ERR! prepareGitDep npm WARN deprecated nodemailer@2.7.2: All versions below 4.0.1 of Nodemailer are deprecated. See https://nodemailer.com/status/
npm ERR! prepareGitDep npm WARN deprecated babel-preset-es2015@6.24.1: :raised_hands: Thanks for using Babel: we recommend using babel-preset-env now: please read babeljs.io/env to update!
npm ERR! prepareGitDep npm WARN deprecated nomnom@1.8.1: Package no longer supported. Contact support@npmjs.com for more info.
npm ERR! prepareGitDep npm WARN deprecated mailcomposer@4.0.1: This project is unmaintained
npm ERR! prepareGitDep npm WARN deprecated socks@1.1.9: If using 2.x branch, please upgrade to at least 2.1.6 to avoid a serious bug with socket data flow and an import issue introduced in 2.1.0
npm ERR! prepareGitDep npm WARN deprecated uws@9.14.0: stop using this version
npm ERR! prepareGitDep npm WARN deprecated node-uuid@1.4.8: Use uuid module instead
npm ERR! prepareGitDep npm WARN deprecated buildmail@4.0.1: This project is unmaintained
npm ERR! prepareGitDep npm WARN deprecated hoek@2.16.3: The major version is no longer supported. Please update to 4.x or newer
npm ERR! prepareGitDep sh: 1: cannot create build_log.txt: Permission denied
npm ERR! prepareGitDep /home/turker/.npm/_cacache/tmp/git-clone-3d715456/node_modules/mkdirp/index.js:90
npm ERR! prepareGitDep throw err0;
npm ERR! prepareGitDep ^
npm ERR! prepareGitDep
npm ERR! prepareGitDep Error: EACCES: permission denied, mkdir ‘/home/turker/.npm/_cacache/tmp/git-clone-3d715456/node_modules/wd/build’
npm ERR! prepareGitDep at Object.fs.mkdirSync (fs.js:885:18)
npm ERR! prepareGitDep at sync (/home/turker/.npm/_cacache/tmp/git-clone-3d715456/node_modules/mkdirp/index.js:71:13)
npm ERR! prepareGitDep at Object. (/home/turker/.npm/_cacache/tmp/git-clone-3d715456/node_modules/wd/scripts/build-browser-scripts.js:6:1)
npm ERR! prepareGitDep at Module._compile (module.js:653:30)
npm ERR! prepareGitDep at Object.Module._extensions…js (module.js:664:10)
npm ERR! prepareGitDep at Module.load (module.js:566:32)
npm ERR! prepareGitDep at tryModuleLoad (module.js:506:12)
npm ERR! prepareGitDep at Function.Module._load (module.js:498:3)
npm ERR! prepareGitDep at Function.Module.runMain (module.js:694:10)
npm ERR! prepareGitDep at startup (bootstrap_node.js:204:16)
npm ERR! prepareGitDep npm WARN karma-webpack@3.0.5 requires a peer of webpack@^2.0.0 || ^3.0.0 but none is installed. You must install peer dependencies yourself.
npm ERR! prepareGitDep npm WARN ajv-keywords@3.2.0 requires a peer of ajv@^6.0.0 but none is installed. You must install peer dependencies yourself.
npm ERR! prepareGitDep npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.4 (node_modules/fsevents):
npm ERR! prepareGitDep npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.4: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“linux”,“arch”:“x64”})
npm ERR! prepareGitDep
npm ERR! prepareGitDep npm ERR! code ELIFECYCLE
npm ERR! prepareGitDep npm ERR! errno 1
npm ERR! prepareGitDep npm ERR! wd@1.11.0 install: node scripts/build-browser-scripts
npm ERR! prepareGitDep npm ERR! Exit status 1
npm ERR! prepareGitDep npm ERR!
npm ERR! prepareGitDep npm ERR! Failed at the wd@1.11.0 install script.
npm ERR! prepareGitDep npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
npm ERR! prepareGitDep
npm ERR! prepareGitDep npm ERR! A complete log of this run can be found in:
npm ERR! prepareGitDep npm ERR! /home/turker/.npm/_logs/2018-10-21T19_56_25_648Z-debug.log
npm ERR! prepareGitDep
npm ERR! code ENOPACKAGEJSON
npm ERR! package.json Non-registry package missing package.json: parchment@github:quilljs/parchment#487850f7eb030a6c4e750ba809e58b09444e0bdb.
npm ERR! package.json npm can’t find a package.json file in your current directory.

npm ERR! A complete log of this run can be found in:
npm ERR! /home/turker/.npm/_logs/2018-10-21T19_56_26_369Z-debug.log

Hi @TurkerTunali have you check the current folder have package.json yet?
and you can remove quill-mention in package.json

I am also having the same issue can you please elaborate more clearly

I’ve deleted that instance but I will try as soon as I get this error again. Should I remove quill-mention from package.json if it is present?

I’ve created new bench. Master branch of frappe doesn’t have any problems for the time being.

bench init frappe-bench --frappe-branch master && cd frappe-bench
bench new-site test1
bench use test1

PS: I’ve also cloned the master branch of the bench before that.
git clone --branch master https://github.com/frappe/bench bench-repo
sudo -H pip install -e bench-repo

@TurkerTunali did that method work? Because I don’t think the master branch is currently working ,just stay on the develop branch, but again i stand to be corrected. You however don’t need to remove the quill-mention from package.json i have it but my Erpnext is working fine.

@Kipngetich33 they fixed it already but maybe didnt merge to master yet

Okay fine