Best way to install stable version of ErpNext

I have been trying to install stable version of ErpNext from last 15 days. I have raised two issues myself and posted two questions.

I am using Ubuntu 16.04.

Following are the things I have tried:

  1. The Hitchhiker’s Guide to Installing Frappé on Linux OS --> developer branch is unstable.switched to master using bench but it’s unstable as well.

  2. Tried Easy Install but it gives an error(Screenshot attached).

While it’s good Erp, I have found it very difficult to install and run a stable version to demo it to clients. Even the master branch is not stable.

Kindly help me out.

Use the manual process on frappe/bench also make sure you have installed all prerequisites.

switched to master using bench but it’s unstable as well.

After bench switch-to-master it becomes important that you do bench update --patch as well. Did you miss this step ?

… equals “The Hitchhiker’s Guide to Installing Frappé on Linux OS” ?

it’s not getting any more stable then master. That said let me add that I am under the impression that most people seem to be quite happy with stability in general.

another howto I have just tested successfully on ubuntu 16.04. (in a LXC container) is this one

Yes, the Hitchhiker’s Guide is the manual approach only.

I did bench update --patch as well after switch-to-master. It gives following error

1 Like

This one should help

then after bench update, run bench update --patch

could not agree more