Try ERPNext Buy Support Partners Foundation

Bench Start Cannot Working

Hi Guys,

I have tried all the method I found from here but still cannot working

The error I faced

10:26:14 system | watch.1 started (pid=17135)
10:26:14 system | redis_socketio.1 started (pid=17134)
10:26:14 system | web.1 started (pid=17137)
10:26:14 system | schedule.1 started (pid=17143)
10:26:14 system | socketio.1 started (pid=17140)
10:26:14 system | redis_cache.1 started (pid=17141)
10:26:14 system | redis_queue.1 started (pid=17144)
10:26:14 redis_socketio.1 | 17145:M 30 Nov 10:26:14.716 # You requested maxclients of 10000 requiring at least 10032 max file descriptors.
10:26:14 redis_socketio.1 | 17145:M 30 Nov 10:26:14.716 # Redis can’t set maximum open files to 10032 because of OS error: Operation not permitted.
10:26:14 redis_socketio.1 | 17145:M 30 Nov 10:26:14.716 # Current maximum open files is 4096. maxclients has been reduced to 4064 to compensate for low ulimit. If you need higher maxclients increase ‘ulimit -n’.
10:26:14 redis_socketio.1 | .
10:26:14 redis_socketio.1 | .-__ ''-._ 10:26:14 redis_socketio.1 | _.- . . ‘’-._ Redis 3.0.6 (00000000/0) 64 bit
10:26:14 redis_socketio.1 | .- .-```. ```\/ _.,_ ''-._ 10:26:14 redis_socketio.1 | ( ' , .-` | `, ) Running in standalone mode 10:26:14 redis_socketio.1 | |`-._`-...-` __...-.-.|’_.-'| Port: 12000 10:26:14 redis_socketio.1 | | -. ._ / _.-' | PID: 17145 10:26:14 redis_socketio.1 | -._ -._ -./ .-’ .-’
10:26:14 redis_socketio.1 | |-._-.
-.__.-' _.-'_.-'| 10:26:14 redis_socketio.1 | | -.
-._ _.-'_.-' | http://redis.io 10:26:14 redis_socketio.1 | -._ -._-..-’.-’ .-’
10:26:14 redis_socketio.1 | |-._-.
-.__.-' _.-'_.-'| 10:26:14 redis_socketio.1 | | -.
-._ _.-'_.-' | 10:26:14 redis_socketio.1 | -._ -._-.
.-’.-’ .-’
10:26:14 redis_socketio.1 | -._ -..-’ _.-’
10:26:14 redis_socketio.1 | -._ _.-' 10:26:14 redis_socketio.1 | -.
.-’
10:26:14 redis_socketio.1 |
10:26:14 redis_socketio.1 | 17145:M 30 Nov 10:26:14.724 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
10:26:14 redis_socketio.1 | 17145:M 30 Nov 10:26:14.725 # Server started, Redis version 3.0.6
10:26:14 redis_socketio.1 | 17145:M 30 Nov 10:26:14.725 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
10:26:14 redis_socketio.1 | 17145:M 30 Nov 10:26:14.726 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
10:26:14 redis_socketio.1 | 17145:M 30 Nov 10:26:14.729 * The server is now ready to accept connections on port 12000
10:26:14 redis_cache.1 | 17155:M 30 Nov 10:26:14.733 # You requested maxclients of 10000 requiring at least 10032 max file descriptors.
10:26:14 redis_queue.1 | 17157:M 30 Nov 10:26:14.736 # You requested maxclients of 10000 requiring at least 10032 max file descriptors.
10:26:14 redis_cache.1 | 17155:M 30 Nov 10:26:14.737 # Redis can’t set maximum open files to 10032 because of OS error: Operation not permitted.
10:26:14 redis_cache.1 | 17155:M 30 Nov 10:26:14.737 # Current maximum open files is 4096. maxclients has been reduced to 4064 to compensate for low ulimit. If you need higher maxclients increase ‘ulimit -n’.
10:26:14 redis_queue.1 | 17157:M 30 Nov 10:26:14.741 # Redis can’t set maximum open files to 10032 because of OS error: Operation not permitted.
10:26:14 redis_cache.1 | .
10:26:14 redis_cache.1 | .-__ ''-._ 10:26:14 redis_cache.1 | _.- . . ‘’-.
Redis 3.0.6 (00000000/0) 64 bit
10:26:14 redis_cache.1 | .- .-```. ```\/ _.,_ ''-._ 10:26:14 redis_cache.1 | ( ' , .-` | `, ) Running in standalone mode 10:26:14 redis_cache.1 | |`-._`-...-` __...-.-.
|’_.-'| Port: 13000 10:26:14 redis_cache.1 | | -._ ._ / _.-' | PID: 17155 10:26:14 redis_cache.1 | -._ -._ -./ .-’ .-’
10:26:14 redis_cache.1 | |-._-.
-.__.-' _.-'_.-'| 10:26:14 redis_cache.1 | | -.
-._ _.-'_.-' | http://redis.io 10:26:14 redis_cache.1 | -._ -._-..-’.-’ .-’
10:26:14 redis_cache.1 | |-._-.
-.__.-' _.-'_.-'| 10:26:14 redis_cache.1 | | -.
-._ _.-'_.-' | 10:26:14 redis_cache.1 | -._ -._-.
.-’_.-’ _.-’
10:26:14 redis_cache.1 | -._ -..-’ _.-’
10:26:14 redis_cache.1 | -._ _.-' 10:26:14 redis_cache.1 | -.
.-’
10:26:14 redis_cache.1 |
10:26:14 redis_cache.1 | 17155:M 30 Nov 10:26:14.746 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
10:26:14 redis_queue.1 | 17157:M 30 Nov 10:26:14.746 # Current maximum open files is 4096. maxclients has been reduced to 4064 to compensate for low ulimit. If you need higher maxclients increase ‘ulimit -n’.
10:26:14 redis_queue.1 | 17157:M 30 Nov 10:26:14.747 # Creating Server TCP listening socket 127.0.0.1:11000: bind: Address already in use
10:26:14 system | redis_queue.1 stopped (rc=1)
10:26:14 system | sending SIGTERM to redis_socketio.1 (pid 17134)
10:26:14 system | sending SIGTERM to watch.1 (pid 17135)
10:26:14 system | sending SIGTERM to web.1 (pid 17137)
10:26:14 system | sending SIGTERM to schedule.1 (pid 17143)
10:26:14 system | sending SIGTERM to socketio.1 (pid 17140)
10:26:14 system | sending SIGTERM to redis_cache.1 (pid 17141)
10:26:14 redis_socketio.1 | 17145:signal-handler (1575080774) Received SIGTERM scheduling shutdown…
10:26:14 redis_socketio.1 | 17145:M 30 Nov 10:26:14.750 # User requested shutdown…
10:26:14 redis_socketio.1 | 17145:M 30 Nov 10:26:14.750 # Redis is now ready to exit, bye bye…
10:26:14 system | redis_socketio.1 stopped (rc=-15)
10:26:14 redis_cache.1 | 17155:M 30 Nov 10:26:14.753 # Server started, Redis version 3.0.6
10:26:14 redis_cache.1 | 17155:M 30 Nov 10:26:14.753 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
10:26:14 redis_cache.1 | 17155:M 30 Nov 10:26:14.753 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
10:26:14 redis_cache.1 | 17155:M 30 Nov 10:26:14.753 * The server is now ready to accept connections on port 13000
10:26:14 system | socketio.1 stopped (rc=-15)
10:26:14 redis_cache.1 | 17155:signal-handler (1575080774) Received SIGTERM scheduling shutdown…
10:26:14 redis_cache.1 | 17155:M 30 Nov 10:26:14.757 # User requested shutdown…
10:26:14 redis_cache.1 | 17155:M 30 Nov 10:26:14.757 # Redis is now ready to exit, bye bye…
10:26:14 system | watch.1 stopped (rc=-15)
10:26:14 system | redis_cache.1 stopped (rc=-15)
10:26:14 system | web.1 stopped (rc=-15)
10:26:14 system | schedule.1 stopped (rc=-15)

bench is already running in background. That’s why you are getting this message.

Hi welcome to ERPNext!

You perhaps have some ‘orphan’ processes running? This should help Error:bench start - 127.0.0.1:11000: bind: Address already in use