ERPNext Foundation ERPNext Cloud User Manual Blog Discuss Frappé* Donate

After Update to 11 "User do not have doctype access via role permission"


#1

Hi All,

I have just moved to V.11 updating from 10 … upgrade was fin, no errors.

when Manager try to approve a stock entry error message appear, I have not yet tested everything, but every thing seems fin.

oh for extra confusion , order some time get approve with blue error , and in other cases dose not with red error


Purchase user encounters error when submitting
Permission Error After upgrade to v11
#2

any help on this please ?


#3

I am facing the same issue and raised it about a month ago and no one has picked it up.

From this i see the issue is not unique to me. It is therefore a bug and this post should be categorized as such.


#4

I’m having the same issue too and I cannot change doctypes


#5

Some suggestions -

Maybe check for issues and add or report problems? https://github.com/frappe/frappe/issues

Be sure to update to get latest commit changes for eg https://github.com/frappe/frappe/pull/7070


#6

I have raised the issue here:

https://github.com/frappe/frappe/issues/7144

I hope someone picks it up soon.


#7

Could it be related to several of the changes introduced to the permission schemes in v11? E.g. also the access to Employees is restriced:


I needed to adjust permissions to get this working after v10 to v11 upgrade. Hope that helps…


#8

Yes while it is connected to changes made to permission schemes in V11, the issue is strange because this happens to users who are not restricted on the doctype via permissions. The users are given broad doctype permissions which removes the Restricted icon visible at the top right end of your screenshot, however the error shown in the screenshot above persists. The first slides in the gif below shows the user does not have Restricted on his purchase order doctype yet the permission error pops up.

What makes it even more weird is the fact that in spite of the permission error which shows up, some of the transactions end up being completed, which means something is not right somewhere as you can see from the image below.


#9

Be sure to upvote the issue [Tutorial] How to upvote Github issues for non developers


#10

I have the same problem,

Our member cannot login to our system :
user do not have document access

Anyone has the solution?

Cheers

Cat


#11

Please upvote the issue on GitHub so it can receive attention.


#12

i’m also getting the same error while updating the Employee details [doctype Employee]
with role : HR user

But the data updating is happening with error .!
image|690x377

did you get any solution?


#13

Getting same error after updating to latest update of erpnext v11, was working fine before the update


#14

In our case, on ly one user was affected. Others were not. The curious thing is that there were no differences in their roles, i.e. My user has same privileges over EPRNext than the affected user.

I had the problem with Employees. I managed to solve it, but (BRACE FOR IT) I do not remember how I did it.
Now this user is having the same issue with tasks assigned by other users. He can see tasks fine, but tasks with assignment from others he cannot see.

** EDIT**
Probable solution: Make sure to be logged in as Administrator whenever you change any permissions.
Even if the Role Permissions are set per doctype, just check to make sure they are.
Go to the user. Remove the roles. Save. Add the roles back again. Save.
This should restore visibility and unrestrict the doctypes.


#15

Have you solved this issue?


#16

The error was while viewing the reports but I don’t remember what I did to resolve it :roll_eyes:


#17

ok the learning for next time - be sure to note whatever you learn here, then you can search back to remind yourself :wink:


#18

The permission issues were fixed via:

and

See


#19

Now that I rechecked still have not resolved this, it was showing on “employee balance leaves” report as I did not have much time I left it as it is that only managers can view that report. For other employees it still shows this error


#20

I am using the master branch as the development branch is not stable, but most of commits are still not merged in master branch. Which branch should I use?