20.02 Bench update error

Hi there,

getting error on bench update:

Backing up sites...
Patching sites...
Migrating is.test
Executing erpnext.patches.v10_0.rename_price_to_rate_in_pricing_rule in is.test (is-test)
Executing erpnext.patches.v10_0.set_currency_in_pricing_rule in is.test (is-test)
Executing execute:frappe.delete_doc('DocType', 'Production Planning Tool', ignore_missing=True) in is.test (is-test)
Updating DocTypes for frappe        : [========================================]
Updating DocTypes for erpnext       : [========================================]
Syncing help database...
Traceback (most recent call last):
  File "/usr/lib/python2.7/runpy.py", line 174, in _run_module_as_main
    "__main__", fname, loader, pkg_name)
  File "/usr/lib/python2.7/runpy.py", line 72, in _run_code
    exec code in run_globals
  File "/home/frappe/frappe-bench/apps/frappe/frappe/utils/bench_helper.py", line 94, in <module>
  File "/home/frappe/frappe-bench/apps/frappe/frappe/utils/bench_helper.py", line 18, in main
  File "/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/click/core.py", line 722, in __call__
    return self.main(*args, **kwargs)
  File "/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/click/core.py", line 697, in main
    rv = self.invoke(ctx)
  File "/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/click/core.py", line 1066, in invoke
    return _process_result(sub_ctx.command.invoke(sub_ctx))
  File "/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/click/core.py", line 1066, in invoke
    return _process_result(sub_ctx.command.invoke(sub_ctx))
  File "/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/click/core.py", line 895, in invoke
    return ctx.invoke(self.callback, **ctx.params)
  File "/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/click/core.py", line 535, in invoke
    return callback(*args, **kwargs)
  File "/home/frappe/frappe-bench/apps/frappe/frappe/commands/utils.py", line 23, in build
    frappe.build.bundle(no_compress, make_copy=make_copy, restore = restore, verbose=verbose)
  File "/home/frappe/frappe-bench/apps/frappe/frappe/build.py", line 35, in bundle
    subprocess.call(command.split(" "), cwd=frappe_app_path)
  File "/usr/lib/python2.7/subprocess.py", line 523, in call
    return Popen(*popenargs, **kwargs).wait()
  File "/usr/lib/python2.7/subprocess.py", line 711, in __init__
    errread, errwrite)
  File "/usr/lib/python2.7/subprocess.py", line 1343, in _execute_child
    raise child_exception
OSError: [Errno 2] No such file or directory

Can someone double check and confirm?


Hi, yes I have the same problem

Try to update again. A fix has been pushed by @netchampfaris

no luck, same error

You need to have yarn globally installed.
Install it using npm install -g yarn
Maybe I should add a message indicating that…

Ah ok, sorry missed that info …let me try

Install solved the prob, now getting:

yarn run v1.3.2
$ FRAPPE_ENV=production rollup -c
/bin/sh: 1: rollup: not found
error Command failed with exit code 127.
info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.

But ended successfully