Year in Naming Series is not getting changed while posting entries in previous year

Hi, community.

Please guide.

Year in Naming Series is not getting changed while posting entries in the previous year.

Hi welcome to ERPNext and thank you for reporting this Jalaj

Please can you post your case example, with specific details to indicate what exactly happens - say a validity check message or error traceback on a save request?

This behaviour may or may not be intended by design.

To note your finding here https://github.com/frappe/erpnext/issues will help direct reviewers to respond to this question.

Hi Clarke

Thanks a lot for your response.

It’s not throwing any error but it’s not working in the way the expected.
As we have year in naming series, so if we are making any entry, like sales invoice, in previous year, say 2019, in naming series the year 2019 should be reflected, but it’s showing 2020 there.

Please provide your valuable comment over it.

Yes please post this to issues for experts to advise. Your question - are entries prior to the current (fiscal?) year a logical reasonable expectation - is to me worth clarification. Reviewers will evaluate whether what you require is a design flaw to be fixed, or the code probably should raise say a validity check failed message in that case.

Thanks Clarke.

Hello. It will use 2020 as the entry is being created in 2020 irrespective of backdating posting date. It you want 2019 then make another naming series and let user choose 2019 or 2020.

Thanks a lot, Muzzy.

HI Muzzy,

Thanks a lot, for your response.

Can we have some automated process, as user need not to select Naming Series, at the time of the creation of the document.

You need to be more clear as to what the automation process should look like.

The simplest way would be to add a Default option via customize form for naming series. The default option will always be picked up when creating a new entry, which the user can change before saving the form.

You can achieve way more with custom scripts.

Hi everyone,
I have the issue like that. After setting naming series like PR-.#### its reflect in the record exactly the same PR-.####.
Can anybody guide me where I am wrong???


got this series???

Looks like you’ve not set Patient Naming By to series:

https://docs.erpnext.com/docs/v13/user/manual/en/healthcare/healthcare_settings

Thank @kennethsequeira its done now.

@kennethsequeira
can you tell me this