Try ERPNext Buy Support Partners Foundation Foundation Members

WORKING - Fingerprint enabled Time and Attendance application for ERPNext

I actually just tried again 10 minutes ago and could download your Git-Thumb-Relase.zip

do you already have an account on github or bitbucket (Github would be the more common provider in the ERPNext world)? If so, what’s your username/ID?

@vrms sorry; I just looked closely at your mail. You have a link. Indeed there seems to be a problem on onedrive; I think it’s microsoft because I can’t access my drive as a whole.

Once I do; I’ll share a link. Thanks.

I actually just tried again 10 minutes ago and could download and unzip the Git-Thumb-Relase.zip

do you already have an account on github or bitbucket (Github would be the more common provider in the ERPNext world)?

If so, what’s your username/ID?
Also we should have a meaninfull name for the App I suggest fingerprint-attendance. Does that work for you?

Thanks a lot @vrms, my git account name is noetico, and yes, the name is fine by me. Thanks a lot.

sorry I didn’t realize that Thumb was your name. Still maybe erpnext_fingerprint-attendance is a bit clearer for everyone.

is the zip file in here https://github.com/noetico/thumb identical with the one from here https://1drv.ms/u/s!Aid3w9N-oNFsmj3Oy5uap4YHeZ-E ?

1 Like

Haha. @vrms, thumb is not my name; that is the initial app name.

haha, that’s what I meant. App name = “Thumb”

Hi @noetico @vrms

Any further updates on this?

Cheers!

1 Like

Where do we get

  1. mysql database name
  2. mysql user name
  3. mysql password

Please help.

In the file Site_config.json file inside the site

Do we also get Mysql Username and Password in site_config.json file?

@noetico Hi, i am very glad to see your struggle for building this feature.
i’ve also tried implementing this but it didn’t work.
i’ve downloaded this and set it up as per user manual.
I’ve putted ip, dbname , dbuser, dbpasword in setup.txt file
but when i am connecting it to server it show below error,
Connection failed with error: Unable to connect to any of the specified MySQL hosts.

please have look into it. your reply will be highly appreciated.

Have you set up the right privileges in mysql? also edit my.cnf; comment out skip-networking and bind-address, add # in front of both lines. Set privileges from the mysql command line.

Sorry buddy i’ve not got your point. please guide step by step or provide documentation if possible.

we have been done it for weighing machines on android!

extremely sorry for the late reply. try the following steps

  1. log into mysql, you can use bench mysql
  2. set privileges as follows: grant all privileges on databaseName TO ‘user’ @’%’ identified by ‘password’ with grant option; hit enter
  3. enter flush privileges; hit enter
  4. edit my.cnf to allow external connections as follows, navigate to etc/mysql and open the my.cnf file, look for bind-address 127.0
    0.1 add a # in front of it, before it like so, #bind-address
  5. add another line, #skip-networking
  6. save file, restart server
    please dont make a mistake in the conf file.

all the best

2 Likes
  1. edit my.cnf to allow external connections as follows, navigate to etc/mysql and open the my.cnf file, look for bind-address 127.0
    0.1 add a # in front of it, before it like so, #bind-address

Can you please explain this step? i am unable to find my.cnf file.

Try this

frappe@erpnext:~/frappe-bench$ find /etc -name '*.cnf' | xargs grep bind-address
find: `/etc/ssl/private': Permission denied
find: `/etc/polkit-1/localauthority': Permission denied
grep: /etc/mysql/debian.cnf: Permission denied
/etc/mysql/my.cnf:#bind-address		= 127.0.0.1
/etc/mysql/my.cnf:bind-address		= 0.0.0.0
1 Like

I’ve tried this and below is the result :

/etc/ssl/openssl.cnf
find: ‘/etc/lvm/backup’: Permission denied
find: ‘/etc/lvm/archive’: Permission denied
/etc/mysql/mariadb.conf.d/erpnext.cnf
/etc/mysql/my.cnf
/etc/mysql/debian.cnf
/etc/mysql/conf.d/settings.cnf
/etc/mysql/conf.d/mysqld_safe_syslog.cnf
/etc/mysql/conf.d/mariadb.cnf

But still i am unable to find the file.

You say this is not the file you require /etc/mysql/my.cnf

In my case that file worked for me.

edit: Here are docs to be found https://mariadb.com/kb/en/library/configuring-mariadb-with-mycnf/