ERPNext Conference 2019* ERPNext.com Blog

Why does my Library Mgt App file structure look different from the docs? Updates?

developer

#7

I’ll try that


#8

do a bench restart too


#9

I have tried with no effect! :sweat_smile:


#10

can u show ur site_config.json file


#11

did u do bench reload/restart


#12

Yes, Nothing!


#13

sit_config.json ??


#14
{
 "db_name": "1bd3e0294da19198", 
 "db_password": "VpX1JJNKputV2VJl", 
 "developer_mode": 1, 
 "limits": {
  "space_usage": {
   "backup_size": 1.0, 
   "database_size": 13.51, 
   "files_size": 2.0, 
   "total": 16.51
  }
 }, 
 "nginx_port": 8001
}

#15

try doing a reload from the desk (from ur user account)


#16

try bench clear-cache


#17

No change


#18

hmm…


#19

Thank you for your effort. Do you know how to switch from Production to Development?

Running bench start only runs into errors

frappe@ubuntu:~/frappe-bench$ bench start
22:28:47 system           | worker_long.1 started (pid=30913)
22:28:47 system           | redis_socketio.1 started (pid=30914)
22:28:47 redis_socketio.1 | 30924:M 17 Aug 22:28:47.174 * Increased maximum number of open files to 10032 (it was originally set to 1024).
22:28:47 redis_socketio.1 | 30924:M 17 Aug 22:28:47.174 # Creating Server TCP listening socket 127.0.0.1:12000: bind: Address already in use
22:28:47 system           | redis_socketio.1 stopped (rc=1)
22:28:47 system           | watch.1 started (pid=30917)
22:28:47 system           | redis_queue.1 started (pid=30915)
22:28:47 redis_queue.1    | 30926:M 17 Aug 22:28:47.185 * Increased maximum number of open files to 10032 (it was originally set to 1024).
22:28:47 redis_queue.1    | 30926:M 17 Aug 22:28:47.185 # Creating Server TCP listening socket 127.0.0.1:11000: bind: Address already in use
22:28:47 system           | redis_queue.1 stopped (rc=1)
22:28:47 system           | schedule.1 started (pid=30916)
22:28:47 system           | web.1 started (pid=30918)
22:28:47 system           | worker_default.1 started (pid=30919)
22:28:47 system           | socketio.1 started (pid=30920)
22:28:47 system           | worker_short.1 started (pid=30938)
22:28:47 system           | redis_cache.1 started (pid=30928)
22:28:47 system           | sending SIGTERM to worker_long.1 (pid 30913)
22:28:47 system           | sending SIGTERM to watch.1 (pid 30917)
22:28:47 system           | sending SIGTERM to web.1 (pid 30918)
22:28:47 system           | sending SIGTERM to schedule.1 (pid 30916)
22:28:47 system           | sending SIGTERM to worker_default.1 (pid 30919)
22:28:47 system           | sending SIGTERM to socketio.1 (pid 30920)
22:28:47 system           | sending SIGTERM to redis_cache.1 (pid 30928)
22:28:47 system           | sending SIGTERM to worker_short.1 (pid 30938)
22:28:47 redis_cache.1    | 30941:M 17 Aug 22:28:47.351 * Increased maximum number of open files to 10032 (it was originally set to 1024).
22:28:47 redis_cache.1    | 30941:M 17 Aug 22:28:47.351 # Creating Server TCP listening socket 127.0.0.1:13000: bind: Address already in use
22:28:47 system           | redis_cache.1 stopped (rc=1)
22:28:47 system           | watch.1 stopped (rc=-15)
22:28:47 system           | worker_long.1 stopped (rc=-15)
22:28:47 system           | web.1 stopped (rc=-15)
22:28:47 system           | schedule.1 stopped (rc=-15)
22:28:47 system           | worker_default.1 stopped (rc=-15)
22:28:47 system           | socketio.1 stopped (rc=-15)
22:28:47 system           | worker_short.1 stopped (rc=-15)

Getting This error after bench start
#20

Hello

“127.0.0.1:11000: bind: Address already in use”

This means your previous server instance did not shutdown cleanly.

To kill those orphan processes run ‘sudo supervisorctl stop all’

That usually works for me…


#21

Thank you so much John Clarke, I’ve been looking for this command. I’m able to start the Dev server now but no way to see what’s happening in the background because for some reason I dont know I can only make 1 connection to my VM. Something I’ve just posted about on AskUbuntu.com.

For now I can stop the server everytime, check if my doctypes are now showing the run bench start again to continue.

Still I cannot see any DocType related files. Perhaps I should start the process again from the begining, this time using bench start. Pheeew :sweat:


#22

I have no experience with that, some ideas:

check /var/log/auth.log for clues why the 2nd connection is always refused or resets?

For verbose debug ssh -v frappe@localhost

turn off fail2ban

This suggests to delete .pub ssh key to test
https://unix.stackexchange.com/questions/151860/ssh-exchange-identification-read-connection-reset-by-peer

FWIW for VM I use qemu-KVM and bridge networking with default PAM and no ssh connection limit problem…


#23

@adam26d try to uncheck ‘custom’ in your doctype and the controller files will appear in the directory structure


#24

I’ve tried this @chrismberi. Next attempt I’ll start again using the dev VM.


#25

FWIW, I was running into a similar issue and unchecking “Custom” in the doctype (which was only available when I was in developer mode) led to the proper directories showing up.

I also did a bench restart and bench migrate before checking if the folders were there, so I’m not sure if they were required or not.


#26

yup…bench restart should fix that…