Try ERPNext Buy Support Partners Foundation

When I try to start bench, I face some error

Hi, when I command shafiq@shafiq-desktop:~/frappe-bench$ bench start ,
the error show .
WARN: bench is installed in editable mode!

This is not the recommended mode of installation for production. Instead, install the package from PyPI with: pip install frappe-bench

07:56:01 system | redis_socketio.1 started (pid=7057)
07:56:01 system | worker_long.1 started (pid=7059)
07:56:01 system | redis_queue.1 started (pid=7068)
07:56:01 system | watch.1 started (pid=7061)
07:56:01 system | redis_cache.1 started (pid=7074)
07:56:01 system | web.1 started (pid=7064)
07:56:01 system | worker_default.1 started (pid=7083)
07:56:01 system | worker_short.1 started (pid=7076)
07:56:01 system | socketio.1 started (pid=7086)
07:56:01 system | schedule.1 started (pid=7088)
07:56:01 redis_socketio.1 | 7066:C 22 Sep 2020 07:56:01.847 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
07:56:01 redis_socketio.1 | 7066:C 22 Sep 2020 07:56:01.847 # Redis version=5.0.7, bits=64, commit=00000000, modified=0, pid=7066, just started
07:56:01 redis_socketio.1 | 7066:C 22 Sep 2020 07:56:01.847 # Configuration loaded
07:56:01 redis_socketio.1 | 7066:M 22 Sep 2020 07:56:01.848 * Increased maximum number of open files to 10032 (it was originally set to 1024).
07:56:01 redis_socketio.1 | 7066:M 22 Sep 2020 07:56:01.848 * Running mode=standalone, port=12000.
07:56:01 redis_socketio.1 | 7066:M 22 Sep 2020 07:56:01.848 # Server initialized
07:56:01 redis_socketio.1 | 7066:M 22 Sep 2020 07:56:01.848 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
07:56:01 redis_socketio.1 | 7066:M 22 Sep 2020 07:56:01.848 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
07:56:01 redis_cache.1 | 7078:C 22 Sep 2020 07:56:01.847 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
07:56:01 redis_cache.1 | 7078:C 22 Sep 2020 07:56:01.847 # Redis version=5.0.7, bits=64, commit=00000000, modified=0, pid=7078, just started
07:56:01 redis_cache.1 | 7078:C 22 Sep 2020 07:56:01.847 # Configuration loaded
07:56:01 redis_cache.1 | 7078:M 22 Sep 2020 07:56:01.848 * Increased maximum number of open files to 10032 (it was originally set to 1024).
07:56:01 redis_cache.1 | 7078:M 22 Sep 2020 07:56:01.848 * Running mode=standalone, port=13000.
07:56:01 redis_cache.1 | 7078:M 22 Sep 2020 07:56:01.848 # Server initialized
07:56:01 redis_cache.1 | 7078:M 22 Sep 2020 07:56:01.848 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
07:56:01 redis_cache.1 | 7078:M 22 Sep 2020 07:56:01.848 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
07:56:01 redis_cache.1 | 7078:M 22 Sep 2020 07:56:01.848 * Ready to accept connections
07:56:01 redis_queue.1 | 7072:C 22 Sep 2020 07:56:01.847 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
07:56:01 redis_queue.1 | 7072:C 22 Sep 2020 07:56:01.847 # Redis version=5.0.7, bits=64, commit=00000000, modified=0, pid=7072, just started
07:56:01 redis_queue.1 | 7072:C 22 Sep 2020 07:56:01.847 # Configuration loaded
07:56:01 redis_queue.1 | 7072:M 22 Sep 2020 07:56:01.848 * Increased maximum number of open files to 10032 (it was originally set to 1024).
07:56:01 redis_queue.1 | 7072:M 22 Sep 2020 07:56:01.848 * Running mode=standalone, port=11000.
07:56:01 redis_queue.1 | 7072:M 22 Sep 2020 07:56:01.848 # Server initialized
07:56:01 redis_queue.1 | 7072:M 22 Sep 2020 07:56:01.848 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
07:56:01 redis_queue.1 | 7072:M 22 Sep 2020 07:56:01.848 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
07:56:01 redis_queue.1 | 7072:M 22 Sep 2020 07:56:01.848 * Ready to accept connections
07:56:01 redis_socketio.1 | 7066:M 22 Sep 2020 07:56:01.848 * Ready to accept connections
07:56:02 watch.1 | WARN: bench is installed in editable mode!
07:56:02 watch.1 |
07:56:02 watch.1 | This is not the recommended mode of installation for production. Instead, install the package from PyPI with: pip install frappe-bench
07:56:02 watch.1 |
07:56:02 schedule.1 | WARN: bench is installed in editable mode!
07:56:02 schedule.1 |
07:56:02 schedule.1 | This is not the recommended mode of installation for production. Instead, install the package from PyPI with: pip install frappe-bench
07:56:02 schedule.1 |
07:56:02 web.1 | WARN: bench is installed in editable mode!
07:56:02 web.1 |
07:56:02 web.1 | This is not the recommended mode of installation for production. Instead, install the package from PyPI with: pip install frappe-bench
07:56:02 web.1 |
07:56:02 socketio.1 | listening on *: 9000
07:56:03 watch.1 | yarn run v1.22.5
07:56:03 web.1 | * Running on http://0.0.0.0:8000/ (Press CTRL+C to quit)
07:56:03 web.1 | * Restarting with inotify reloader
07:56:03 watch.1 | $ node rollup/watch.js
07:56:03 watch.1 | /home/shafiq/node_modules/rollup-plugin-terser/node_modules/jest-worker/build/WorkerPool.js:25
07:56:03 watch.1 | } catch {
07:56:03 watch.1 | ^
07:56:03 watch.1 |
07:56:03 watch.1 | SyntaxError: Unexpected token {
07:56:03 watch.1 | at createScript (vm.js:80:10)
07:56:03 watch.1 | at Object.runInThisContext (vm.js:139:10)
07:56:03 watch.1 | at Module._compile (module.js:617:28)
07:56:03 watch.1 | at Object.Module._extensions…js (module.js:664:10)
07:56:03 watch.1 | at Module.load (module.js:566:32)
07:56:03 watch.1 | at tryModuleLoad (module.js:506:12)
07:56:03 watch.1 | at Function.Module._load (module.js:498:3)
07:56:03 watch.1 | at Module.require (module.js:597:17)
07:56:03 watch.1 | at require (internal/module.js:11:18)
07:56:03 watch.1 | at Object. (/home/shafiq/node_modules/rollup-plugin-terser/node_modules/jest-worker/build/index.js:24:42)
07:56:03 watch.1 | error Command failed with exit code 1.
07:56:03 watch.1 | info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.
07:56:03 system | watch.1 stopped (rc=0)
07:56:03 system | sending SIGTERM to redis_socketio.1 (pid 7057)
07:56:03 system | sending SIGTERM to worker_long.1 (pid 7059)
07:56:03 system | sending SIGTERM to redis_queue.1 (pid 7068)
07:56:03 system | sending SIGTERM to web.1 (pid 7064)
07:56:03 system | sending SIGTERM to schedule.1 (pid 7088)
07:56:03 system | sending SIGTERM to worker_default.1 (pid 7083)
07:56:03 system | sending SIGTERM to socketio.1 (pid 7086)
07:56:03 system | sending SIGTERM to redis_cache.1 (pid 7074)
07:56:03 system | sending SIGTERM to worker_short.1 (pid 7076)
07:56:03 system | worker_default.1 stopped (rc=-15)
07:56:03 system | schedule.1 stopped (rc=-15)
07:56:03 redis_queue.1 | 7072:signal-handler (1600739763) Received SIGTERM scheduling shutdown…
07:56:03 redis_cache.1 | 7078:signal-handler (1600739763) Received SIGTERM scheduling shutdown…
07:56:03 system | worker_long.1 stopped (rc=-15)
07:56:03 redis_socketio.1 | 7066:signal-handler (1600739763) Received SIGTERM scheduling shutdown…
07:56:03 system | worker_short.1 stopped (rc=-15)
07:56:03 system | socketio.1 stopped (rc=-15)
07:56:04 redis_cache.1 | 7078:M 22 Sep 2020 07:56:04.053 # User requested shutdown…
07:56:04 redis_cache.1 | 7078:M 22 Sep 2020 07:56:04.053 * Removing the pid file.
07:56:04 redis_cache.1 | 7078:M 22 Sep 2020 07:56:04.053 # Redis is now ready to exit, bye bye…
07:56:04 system | redis_cache.1 stopped (rc=-15)
07:56:04 redis_socketio.1 | 7066:M 22 Sep 2020 07:56:04.057 # User requested shutdown…
07:56:04 redis_socketio.1 | 7066:M 22 Sep 2020 07:56:04.057 * Removing the pid file.
07:56:04 redis_socketio.1 | 7066:M 22 Sep 2020 07:56:04.057 # Redis is now ready to exit, bye bye…
07:56:04 system | redis_socketio.1 stopped (rc=-15)
07:56:04 redis_queue.1 | 7072:M 22 Sep 2020 07:56:04.063 # User requested shutdown…
07:56:04 redis_queue.1 | 7072:M 22 Sep 2020 07:56:04.064 * Removing the pid file.
07:56:04 redis_queue.1 | 7072:M 22 Sep 2020 07:56:04.064 # Redis is now ready to exit, bye bye…
07:56:04 system | redis_queue.1 stopped (rc=-15)
07:56:04 system | web.1 stopped (rc=-15)