Try ERPNext Buy Support Partners Foundation

Warnings and Errors during installation

Hi, I tried to install ERPNext these days, but have not succeeded yet.

Now, I tried to install it on fresh Ubuntu 18.04 based on the The Hitchhiker’s Guide to Installing Frappe on Linux step by step.

Some problems appeared during the ‘Bench init’

  1. two warnings in first yarn install
    [3/4] linking dependencies…
    bootstrap@4.3.1 has unmet peer dependency jquery@1.9.1 - 3
    bootstrap@4.3.1 has unmet peer dependency popper.js@^1.14.7
  2. one error in building frappe assets
    built js/barcode_scanner.min.js
    Browserslit: caniuse-lite is outdated. Please run next command ‘yarn upgrade caniuse-lite browserslist’

I tried to deleted the frappe-bench folder, then run ‘sudo npm i -g caniuse-lite’ and ‘sudo npm i -g browserslist’ using the admin account. After that I run the ‘Bench init’ using the bench account. But the problems happened again.

Please help me to fix the issue.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.