Try ERPNext Buy Support Partners Foundation

WARN: bench is installed in editable mode! Why i cant run bench commend i am getting this error

Dear Team
i am using ERPNext with AWS bitnami image
i can work everything but i can’t run like this bench commend
bench --version
bench update

if i run i got this error
WARN: bench is installed in editable mode!

can u help me solve this issue
for more details please see this images

@Shiraz_KI

WARN: Command not being executed in bench directory

This says it all. Execute all bench commands such as update, build, etc. from the frappe-bench directory.

You are running this currently from the user’s directory. Check first where the frappe-bench directory is. Run ls to list all files and directories from the current one.

2 Likes

Just as @kennethsequeira mentioned. I’d like to add that if you aren’t sure of the location of your bench, you can also use bench find . to search for benches from your current working directory recursively.

Note: bench find is to be used only if you have a lot of benches spread across different directories. Conventionally, benches are named frappe-bench and created under your home directory

2 Likes

I try bro but i got same error

bro my warn actually like this WARN: bench is installed in editable mode!
and i try this directory also

1 Like

The warning is shown because of how you installed bench.

Check this thread for the answer related to the warning:

Also you probably want to identify what and where your bench directory is in your particular case?

For eg with the standard install, a typical frappe user account and bench init frappe-bench will result in this /home/frappe/frappe-bench.

To check other bitnami environments should help solve your case Bench Migrate ERROR - Your system is being updated. Please refresh again after a few moments

Also the sale problem!

Installed pip install frappe-bench

WARN: bench is installed in editable mode!

Also in AWS EC2

After you ssh login to your account, did you find this directory ?

cd /opt/bitnami/apps/erpnext/htdocs/frappe-bench

This suggests that is the bench directory’s default location
https://docs.bitnami.com/oci/apps/erpnext/administration/upgrade/

That means your system is using the editable install although you may have installed the PyPI package over that. Remove all traces of the editable install as well.