ERPNext Foundation ERPNext Cloud Chat Blog Discuss Frappé* Donate

VirtualBox Won't Run - raw-mode unavailable courtesy of Hyper-V?

virtual_machine

#7

I am having the same issue and verified Hyper V is not installed


#8

How about temporarily turn off virtualization in the BIOS?

That might persuade Hyper-V to let go here?


#9

After some research via duckduckgo.com… vaguely/possibly this is of a bit of use


#10

Hi guys,

Sorry I am responding late. I hope my contribution will be of help though. I managed to resolve the issue but not by uninstalling Hyper-V. I saw a couple of suggestions but I find this one situable (it makes sense since I’m not an IT guru):

STEP 1:
Open the command prompt as an Administrator.

STEP 2:
Run the command with no argument: bcdedit

After you run the above command, you will see that the property hypervisorlaunchtype is set Auto by default. See screenshot below:

STEP 3:
Disable Hyper-V by running the command: bcdedit /set hypervisorlaunchtype off

STEP 4:
Restart your PC system to use VirtualBox.

To turn Hyper-V back on, run the command: bcdedit /set hypervisorlaunchtype auto
You will need to reboot the system to use Hyper-V.


#11

If yo do that, you will get this error message: image


#12

Yes, finally i managed to make it work. Sirjames, I used your suggestion, but deactivating (bcdedit /set hypervisorlaunchtype off), restart and reactivating (bcdedit /set hypervisorlaunchtype auto) does nothing for me. And than i have tried only the deactivation part (bcdedit /set hypervisorlaunchtype off) and restart… Now I have 4 VM’s running in the same time and no issue.


Thank you very much Sirjames. You were a very big help :smiley:


#13

Thanks, it works for me!
If we have more than one OS then can run:

bcdedit /set {current} hypervisorlaunchtype off

accordingf to this:https://docs.microsoft.com/en-us/windows-hardware/drivers/devtest/bcdedit--set


#14

Worked for me, thank you very much!


#15

Thanks Sirjames tjis helped


#16

Dosen’t work for me, I tried the command bcdedit /set hypervisorlaunchtype off, but nothing…


#17

Also ensure that Windows 10 developer mode isn’t enabled.


#18

The answer to this thread left me with a BSoD upon restarting, does anyone know why?


#19

What’s the error code on the BSOD?


#20

Hi @MirkoD2, did you restart your PC after you tried the command?

I had a similar experience before I got it right. In fact, it happened to me twice. It will not work for you if any of these two scenarios happened:

a) If you did not RESTART the system after you tried the command bcdedit /set hypervisorlaunchtype off.

b) If you SHUTDOWN the PC (instead of RESTART) after the bcdedit /set hypervisorlaunchtype off command.

In both cases, it did not work for me. I had to undo the whole thing just to be safe (i.e., I ran the command bcdedit /set hypervisorlaunchtype auto and restarted the PC.)

Then I tried the bcdedit /set hypervisorlaunchtype off command again and restarted the PC. That was when it worked.

Hope this helps.


#21

Having the same issue. The Virtual Machine does not boot at all. Am not a tech guy, so am pretty stuck. Have tried with the Production image, and then with the Development image. Same issue on both.

What’s the secret to get the Virtual Machine to run?

Currently on Windows 10.


#22

Hi @abidomar,

Which virtual machine are you referring to? Virtualbox?


#23

If you’re not actually using Hyper-V, have you tried uninstalling Hyper-V and then running the Virtual Box VM?


#24

Using VirtualBox. Have tried disabling Hyper-V as per @Sirjames, but haven’t uninstalled.


#25

SirJames method is superior to uninstalling, but if that doesn’t work for you, and you aren’t using Hyper-V, then this would be a backup plan


#26

Found the solution. Virtualization was disabled in the BIOS. Needed to enable virtualization, and it works like a charm.