Versions , Installations , Development

Hello ,

I just bumped into ERPNext today and thought it was amazing.
So without wasting time I wanted to get into the codes and more details

So now this is where I get confused.

The version I downloaded to review was ERPnext 1.0
The framework version was wnframework 1.7 I think ?

The version that I reviewed online was different
The framework version running this is different? 2.0?

I read on a blog that ERPNext is being re written from scratch and to continue support development of the old one is also being worked on . So 2 different branches.
Where can I can access these 2 branches?
Will the app work irrespective of the framework version?

Is there a blog / documentation were I could find a guide to all the tables ,relations etc
Is there a blog / documentation were I could find a guide to begin writing addon modules for ERPnext?



You received this message because you are subscribed to the Google Groups “ERPNext Technical Forum” group.

To view this discussion on the web visit https://groups.google.com/d/msg/wnframework/-/L0CnUIoBiAYJ.

To post to this group, send email to wn...@googlegroups.com.

To unsubscribe from this group, send email to wnframework+un...@googlegroups.com.

For more options, visit this group at http://groups.google.com/group/wnframework?hl=en.

On 10-Mar-2012, at 3:35 PM, Vivek wrote:

Hello ,

I just bumped into ERPNext today and thought it was amazing.
So without wasting time I wanted to get into the codes and more details

So now this is where I get confused.

The version I downloaded to review was ERPnext 1.0
The framework version was wnframework 1.7 I think ?

The version that I reviewed online was different
The framework version running this is different? 2.0?

I am guessing that you downloaded form erpnext-1.0.0.tar.gz from http://erpnext.org. This tarball was built long ago.

I read on a blog that ERPNext is being re written from scratch and to continue support development of the old one is also being worked on . So 2 different branches.
Where can I can access these 2 branches?
Will the app work irrespective of the framework version?

True. Here are the links to the repositories (If you don’t have/want_to install git, download the zip)

Is there a blog / documentation were I could find a guide to all the tables ,relations etc
Is there a blog / documentation were I could find a guide to begin writing addon modules for ERPnext?


You received this message because you are subscribed to the Google Groups “ERPNext Technical Forum” group.
To view this discussion on the web visit https://groups.google.com/d/msg/wnframework/-/L0CnUIoBiAYJ.
To post to this group, send email to wn...@googlegroups.com.
To unsubscribe from this group, send email to wnframework+un...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/wnframework?hl=en.


Pratik Vyas
Twitter : @pdvyas

ERPNext - World’s most affordable ERP - (Rs 299 / $7 per user per month)
Website: https://www.erpnext.com


You received this message because you are subscribed to the Google Groups “ERPNext Technical Forum” group.
To post to this group, send email to wn...@googlegroups.com.
To unsubscribe from this group, send email to wnframework+un...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/wnframework?hl=en.

Hi Vivek,
I am wondering if you ran the installer from the other tarball.
Let us know what errors you run into.
Also, when you setup wnframework, use the master.sql from the erpnext project right away as you are primarily interested in getting erpnext to work.


Pratik Vyas
Twitter : @pdvyas

ERPNext - World’s most affordable ERP - (Rs 299 / $7 per user per month)
Website: https://www.erpnext.com

On 10-Mar-2012, at 3:35 PM, Vivek wrote:

Hello ,

I just bumped into ERPNext today and thought it was amazing.
So without wasting time I wanted to get into the codes and more details

So now this is where I get confused.

The version I downloaded to review was ERPnext 1.0
The framework version was wnframework 1.7 I think ?

The version that I reviewed online was different
The framework version running this is different? 2.0?

I read on a blog that ERPNext is being re written from scratch and to continue support development of the old one is also being worked on . So 2 different branches.
Where can I can access these 2 branches?
Will the app work irrespective of the framework version?

Is there a blog / documentation were I could find a guide to all the tables ,relations etc
Is there a blog / documentation were I could find a guide to begin writing addon modules for ERPnext?


You received this message because you are subscribed to the Google Groups “ERPNext Technical Forum” group.
To view this discussion on the web visit https://groups.google.com/d/msg/wnframework/-/L0CnUIoBiAYJ.
To post to this group, send email to wn...@googlegroups.com.
To unsubscribe from this group, send email to wnframework+un...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/wnframework?hl=en.


You received this message because you are subscribed to the Google Groups “ERPNext Technical Forum” group.
To post to this group, send email to wn...@googlegroups.com.
To unsubscribe from this group, send email to wnframework+un...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/wnframework?hl=en.


Ok finally I got it running!! . Excited ! I guess now if I check the documentation on wnframework module development , I can get a picture of ERPnext. But if there is some documents with the doctypes and so on it would be great! I would definitely want to be able to contribute quicker!



You received this message because you are subscribed to the Google Groups “ERPNext Technical Forum” group.

To view this discussion on the web visit https://groups.google.com/d/msg/wnframework/-/zQlQ3NTKSfkJ.

To post to this group, send email to wn...@googlegroups.com.

To unsubscribe from this group, send email to wnframework+un...@googlegroups.com.

For more options, visit this group at http://groups.google.com/group/wnframework?hl=en.

On 11-Mar-2012, at 12:06 AM, Vivek wrote:

Ok finally I got it running!! . Excited ! I guess now if I check the documentation on wnframework module development , I can get a picture of ERPnext. But if there is some documents with the doctypes and so on it would be great! I would definitely want to be able to contribute quicker!

I am happy to know that you have erpnext running and the night is still young to explore it further :slight_smile:
Regarding development of wnframework modules, you’ll have to wait for Rushabh to reply.

Till then you can start fiddling with existing erpnext modules.

Umair maintains a user guide at http://erpnext.blogspot.in/2011/03/erpnext-help.html


You received this message because you are subscribed to the Google Groups “ERPNext Technical Forum” group.
To view this discussion on the web visit https://groups.google.com/d/msg/wnframework/-/zQlQ3NTKSfkJ.
To post to this group, send email to wn...@googlegroups.com.
To unsubscribe from this group, send email to wnframework+un...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/wnframework?hl=en.


Pratik Vyas
Twitter : @pdvyas

ERPNext - World’s most affordable ERP - (Rs 299 / $7 per user per month)
Website: https://www.erpnext.com


You received this message because you are subscribed to the Google Groups “ERPNext Technical Forum” group.
To post to this group, send email to wn...@googlegroups.com.
To unsubscribe from this group, send email to wnframework+un...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/wnframework?hl=en.

Hi Vivek,

Thanks for your interest. It will be great if you can introduce yourself. Whatever code documentation we have is on github.

best,
Rushabh

On 11-Mar-2012, at 12:19 AM, Pratik Vyas wrote:

On 11-Mar-2012, at 12:06 AM, Vivek wrote:

Ok finally I got it running!! . Excited ! I guess now if I check the documentation on wnframework module development , I can get a picture of ERPnext. But if there is some documents with the doctypes and so on it would be great! I would definitely want to be able to contribute quicker!

I am happy to know that you have erpnext running and the night is still young to explore it further :slight_smile:
Regarding development of wnframework modules, you’ll have to wait for Rushabh to reply.

Till then you can start fiddling with existing erpnext modules.

Umair maintains a user guide at http://erpnext.blogspot.in/2011/03/erpnext-help.html


You received this message because you are subscribed to the Google Groups “ERPNext Technical Forum” group.
To view this discussion on the web visit https://groups.google.com/d/msg/wnframework/-/zQlQ3NTKSfkJ.
To post to this group, send email to wn...@googlegroups.com.
To unsubscribe from this group, send email to wnframework+un...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/wnframework?hl=en.


Pratik Vyas
Twitter : @pdvyas

ERPNext - World’s most affordable ERP - (Rs 299 / $7 per user per month)
Website: https://www.erpnext.com


You received this message because you are subscribed to the Google Groups “ERPNext Technical Forum” group.
To post to this group, send email to wn...@googlegroups.com.
To unsubscribe from this group, send email to wnframework+un...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/wnframework?hl=en.


You received this message because you are subscribed to the Google Groups “ERPNext Technical Forum” group.
To post to this group, send email to wn...@googlegroups.com.
To unsubscribe from this group, send email to wnframework+un...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/wnframework?hl=en.

Am an open source enthusiast . Makes a living by providing open source solutions for small companies. I started off with Adempiere quickly left it to work on OpenERP . And just a few days back I came across erpnext! I would want to start providing services in it as soon as I get comfortable with it. 



On Monday, March 12, 2012 8:59:51 AM UTC+4, rushabh wrote:

Hi Vivek,

Thanks for your interest. It will be great if you can introduce yourself. Whatever code documentation we have is on github.

best,
Rushabh

On 11-Mar-2012, at 12:19 AM, Pratik Vyas wrote:

>
> On 11-Mar-2012, at 12:06 AM, Vivek wrote:
>
>>
>> Ok finally I got it running!! . Excited ! I guess now if I check the documentation on wnframework module development , I can get a picture of ERPnext. But if there is some documents with the doctypes and so on it would be great! I would definitely want to be able to contribute quicker!
>>
>
> I am happy to know that you have erpnext running and the night is still young to explore it further :slight_smile:
> Regarding development of wnframework modules, you’ll have to wait for Rushabh to reply.
>
> Till then you can start fiddling with existing erpnext modules.
>
> Umair maintains a user guide at http://erpnext.blogspot.in/2011/03/erpnext-help.html
>
>> –
>> You received this message because you are subscribed to the Google Groups “ERPNext Technical Forum” group.
>> To view this discussion on the web visit https://groups.google.com/d/msg/wnframework/-/zQlQ3NTKSfkJ.
>> To post to this group, send email to wn…@googlegroups.com.
>> To unsubscribe from this group, send email to wnframework+unsubscribe@googlegroups.com.
>> For more options, visit this group at http://groups.google.com/group/wnframework?hl=en.
>
> –
> Pratik Vyas
> Twitter : @pdvyas
>
> ERPNext - World’s most affordable ERP - (Rs 299 / $7 per user per month)
> Website: https://www.erpnext.com
>
> –
> You received this message because you are subscribed to the Google Groups “ERPNext Technical Forum” group.
> To post to this group, send email to wn…@googlegroups.com.
> To unsubscribe from this group, send email to wnframework+unsubscribe@googlegroups.com.
> For more options, visit this group at http://groups.google.com/group/wnframework?hl=en.
>



You received this message because you are subscribed to the Google Groups “ERPNext Technical Forum” group.

To view this discussion on the web visit https://groups.google.com/d/msg/wnframework/-/0YBZsKbWSqsJ.

To post to this group, send email to wn...@googlegroups.com.

To unsubscribe from this group, send email to wnframework+un...@googlegroups.com.

For more options, visit this group at http://groups.google.com/group/wnframework?hl=en.

Hi,

Tried to install latest version, executed command:
python py/webnotes/install_lib/install.py root pass erpnextnew
but got an error:
_mysql_exceptions.ProgrammingError: (1146, “Table
‘erpnextnew.tabDocType’ doesn’t exist”)
although I see that table in mysql administrator gui in scheme
“erpnextnew”.
What am I doing wrong?

On Mar 10, 2:31 pm, Pratik Vyas pd...@erpnext.com wrote:

On 10-Mar-2012, at 3:35 PM, Vivek wrote:

Hello ,

I just bumped into ERPNext today and thought it was amazing.
So without wasting time I wanted to get into the codes and more details

So now this is where I get confused.

The version I downloaded to review was ERPnext 1.0
The framework version was wnframework 1.7 I think ?

The version that I reviewed online was different
The framework version running this is different? 2.0?

I am guessing that you downloaded form erpnext-1.0.0.tar.gz fromhttp://erpnext.org. This tarball was built long ago.

I read on a blog that ERPNext is being re written from scratch and to continue support development of the old one is also being worked on . So 2 different branches.
Where can I can access these 2 branches?
Will the app work irrespective of the framework version?

True. Here are the links to the repositories (If you don’t have/want_to install git, download the zip)

https://github.com/webnotes/wnframeworkhttps://github.com/webnotes/erpnext

Is there a blog / documentation were I could find a guide to all the tables ,relations etc
Is there a blog / documentation were I could find a guide to begin writing addon modules for ERPnext?


You received this message because you are subscribed to the Google Groups “ERPNext Technical Forum” group.
To view this discussion on the web visithttps://groups.google.com/d/msg/wnframework/-/L0CnUIoBiAYJ.
To post to this group, send email to wn...@googlegroups.com.
To unsubscribe from this group, send email to wnframework+un...@googlegroups.com.
For more options, visit this group athttp://groups.google.com/group/wnframework?hl=en.


Pratik Vyas
Twitter : @pdvyas

ERPNext - World’s most affordable ERP - (Rs 299 / $7 per user per month)
Website:https://www.erpnext.com


You received this message because you are subscribed to the Google Groups “ERPNext Technical Forum” group.
To post to this group, send email to wn...@googlegroups.com.
To unsubscribe from this group, send email to wnframework+un...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/wnframework?hl=en.

Hi,
On 16-Mar-2012, at 12:13 AM, AntonK wrote:

Hi,

Tried to install latest version, executed command:
python py/webnotes/install_lib/install.py root pass erpnextnew
but got an error:
_mysql_exceptions.ProgrammingError: (1146, “Table
‘erpnextnew.tabDocType’ doesn’t exist”)
although I see that table in mysql administrator gui in scheme
“erpnextnew”.
What am I doing wrong?

Use the master.sql from erpnext project,

python py/webnotes/install_lib/install.py root pass erpnextnew -s path/to/erpnext/data/master.sql

You will have to inflate master.sql from master.sql.gz

On Mar 10, 2:31 pm, Pratik Vyas pd...@erpnext.com wrote:

On 10-Mar-2012, at 3:35 PM, Vivek wrote:

Hello ,

I just bumped into ERPNext today and thought it was amazing.
So without wasting time I wanted to get into the codes and more details

So now this is where I get confused.

The version I downloaded to review was ERPnext 1.0
The framework version was wnframework 1.7 I think ?

The version that I reviewed online was different
The framework version running this is different? 2.0?

I am guessing that you downloaded form erpnext-1.0.0.tar.gz fromhttp://erpnext.org. This tarball was built long ago.

I read on a blog that ERPNext is being re written from scratch and to continue support development of the old one is also being worked on . So 2 different branches.
Where can I can access these 2 branches?
Will the app work irrespective of the framework version?

True. Here are the links to the repositories (If you don’t have/want_to install git, download the zip)

https://github.com/webnotes/wnframeworkhttps://github.com/webnotes/erpnext

Is there a blog / documentation were I could find a guide to all the tables ,relations etc
Is there a blog / documentation were I could find a guide to begin writing addon modules for ERPnext?


You received this message because you are subscribed to the Google Groups “ERPNext Technical Forum” group.
To view this discussion on the web visithttps://groups.google.com/d/msg/wnframework/-/L0CnUIoBiAYJ.
To post to this group, send email to wn...@googlegroups.com.
To unsubscribe from this group, send email to wnframework+un...@googlegroups.com.
For more options, visit this group athttp://groups.google.com/group/wnframework?hl=en.


Pratik Vyas
Twitter : @pdvyas

ERPNext - World’s most affordable ERP - (Rs 299 / $7 per user per month)
Website:https://www.erpnext.com


You received this message because you are subscribed to the Google Groups “ERPNext Technical Forum” group.
To post to this group, send email to wn...@googlegroups.com.
To unsubscribe from this group, send email to wnframework+un...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/wnframework?hl=en.

Pratik,

install script worked fine, then I modified defs.py and created
symlink in erpnext to wnframework, but in browser I get next message:
A problem occurred in a Python script. Here is the sequence of
function calls leading up to the error, in the order they occurred.
/home/akey/erpnext/index.cgi in ()
70 print webnotes.cms.index.get()
71
72 if name==“main”:
73 if init():
=> 74 respond()
respond =
/home/akey/erpnext/index.cgi in respond()
68 webnotes.handler.print_cookies()
69 print
=> 70 print webnotes.cms.index.get()
71
72 if name==“main”:
webnotes = <module ‘webnotes’ from ‘lib/py/webnotes/init.pyc’>,
webnotes.cms = <module ‘webnotes.cms’ from ‘lib/py/webnotes/cms/
init.py’>, webnotes.cms.index = <module ‘webnotes.cms.index’ from
‘lib/py/webnotes/cms/index.py’>, webnotes.cms.index.get =
/home/akey/erpnext/lib/py/webnotes/cms/index.py in get()
53 “”“get index html”""
54 import webnotes
=> 55 from jinja2 import Template
56
57 with open(‘lib/conf/index.html’, ‘r’) as f:
jinja2 undefined, Template undefined

<type ‘exceptions.ImportError’>: No module named jinja2
args = (‘No module named jinja2’,)
message = ‘No module named jinja2’

On Mar 15, 10:51 pm, Pratik Vyas pd...@gmail.com wrote:

Hi,
On 16-Mar-2012, at 12:13 AM, AntonK wrote:

Hi,

Tried to install latest version, executed command:
python py/webnotes/install_lib/install.py root pass erpnextnew
but got an error:
_mysql_exceptions.ProgrammingError: (1146, “Table
‘erpnextnew.tabDocType’ doesn’t exist”)
although I see that table in mysql administrator gui in scheme
“erpnextnew”.
What am I doing wrong?

Use the master.sql from erpnext project,

python py/webnotes/install_lib/install.py root pass erpnextnew -s path/to/erpnext/data/master.sql

You will have to inflate master.sql from master.sql.gz

On Mar 10, 2:31 pm, Pratik Vyas pd...@erpnext.com wrote:

On 10-Mar-2012, at 3:35 PM, Vivek wrote:

Hello ,

I just bumped into ERPNext today and thought it was amazing.
So without wasting time I wanted to get into the codes and more details

So now this is where I get confused.

The version I downloaded to review was ERPnext 1.0
The framework version was wnframework 1.7 I think ?

The version that I reviewed online was different
The framework version running this is different? 2.0?

I am guessing that you downloaded form erpnext-1.0.0.tar.gz fromhttp://erpnext.org. This tarball was built long ago.

I read on a blog that ERPNext is being re written from scratch and to continue support development of the old one is also being worked on . So 2 different branches.
Where can I can access these 2 branches?
Will the app work irrespective of the framework version?

True. Here are the links to the repositories (If you don’t have/want_to install git, download the zip)

https://github.com/webnotes/wnframeworkhttps://github.com/webnotes/er

Is there a blog / documentation were I could find a guide to all the tables ,relations etc
Is there a blog / documentation were I could find a guide to begin writing addon modules for ERPnext?


You received this message because you are subscribed to the Google Groups “ERPNext Technical Forum” group.
To view this discussion on the web visithttps://groups.google.com/d/msg/wnframework/-/L0CnUIoBiAYJ.
To post to this group, send email to wn...@googlegroups.com.
To unsubscribe from this group, send email to wnframework+un...@googlegroups.com.
For more options, visit this group athttp://groups.google.com/group/wnframework?hl=en.


Pratik Vyas
Twitter : @pdvyas

ERPNext - World’s most affordable ERP - (Rs 299 / $7 per user per month)
Website:https://www.erpnext.com


You received this message because you are subscribed to the Google Groups “ERPNext Technical Forum” group.
To post to this group, send email to wn...@googlegroups.com.
To unsubscribe from this group, send email to wnframework+un...@googlegroups.com.
For more options, visit this group athttp://groups.google.com/group/wnframework?hl=en.


You received this message because you are subscribed to the Google Groups “ERPNext Technical Forum” group.
To post to this group, send email to wn...@googlegroups.com.
To unsubscribe from this group, send email to wnframework+un...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/wnframework?hl=en.

Hey Anton,

Just run

sudo easy_install jinja2

on the terminal


Pratik Vyas
Twitter : @pdvyas

ERPNext - World’s most affordable ERP - (Rs 299 / $7 per user per month)
Website: https://www.erpnext.com

On 16-Mar-2012, at 1:39 AM, AntonK wrote:

Pratik,

install script worked fine, then I modified defs.py and created
symlink in erpnext to wnframework, but in browser I get next message:
A problem occurred in a Python script. Here is the sequence of
function calls leading up to the error, in the order they occurred.
/home/akey/erpnext/index.cgi in ()
70 print webnotes.cms.index.get()
71
72 if name==“main”:
73 if init():
=> 74 respond()
respond =
/home/akey/erpnext/index.cgi in respond()
68 webnotes.handler.print_cookies()
69 print
=> 70 print webnotes.cms.index.get()
71
72 if name==“main”:
webnotes = <module ‘webnotes’ from ‘lib/py/webnotes/init.pyc’>,
webnotes.cms = <module ‘webnotes.cms’ from ‘lib/py/webnotes/cms/
init.py’>, webnotes.cms.index = <module ‘webnotes.cms.index’ from
‘lib/py/webnotes/cms/index.py’>, webnotes.cms.index.get =
/home/akey/erpnext/lib/py/webnotes/cms/index.py in get()
53 “”“get index html”""
54 import webnotes
=> 55 from jinja2 import Template
56
57 with open(‘lib/conf/index.html’, ‘r’) as f:
jinja2 undefined, Template undefined

<type ‘exceptions.ImportError’>: No module named jinja2
args = (‘No module named jinja2’,)
message = ‘No module named jinja2’

On Mar 15, 10:51 pm, Pratik Vyas pd...@gmail.com wrote:

Hi,
On 16-Mar-2012, at 12:13 AM, AntonK wrote:

Hi,

Tried to install latest version, executed command:
python py/webnotes/install_lib/install.py root pass erpnextnew
but got an error:
_mysql_exceptions.ProgrammingError: (1146, “Table
‘erpnextnew.tabDocType’ doesn’t exist”)
although I see that table in mysql administrator gui in scheme
“erpnextnew”.
What am I doing wrong?

Use the master.sql from erpnext project,

python py/webnotes/install_lib/install.py root pass erpnextnew -s path/to/erpnext/data/master.sql

You will have to inflate master.sql from master.sql.gz

On Mar 10, 2:31 pm, Pratik Vyas pd...@erpnext.com wrote:

On 10-Mar-2012, at 3:35 PM, Vivek wrote:

Hello ,

I just bumped into ERPNext today and thought it was amazing.
So without wasting time I wanted to get into the codes and more details

So now this is where I get confused.

The version I downloaded to review was ERPnext 1.0
The framework version was wnframework 1.7 I think ?

The version that I reviewed online was different
The framework version running this is different? 2.0?

I am guessing that you downloaded form erpnext-1.0.0.tar.gz fromhttp://erpnext.org. This tarball was built long ago.

I read on a blog that ERPNext is being re written from scratch and to continue support development of the old one is also being worked on . So 2 different branches.
Where can I can access these 2 branches?
Will the app work irrespective of the framework version?

True. Here are the links to the repositories (If you don’t have/want_to install git, download the zip)

https://github.com/webnotes/wnframeworkhttps://github.com/webnotes/er

Is there a blog / documentation were I could find a guide to all the tables ,relations etc
Is there a blog / documentation were I could find a guide to begin writing addon modules for ERPnext?


You received this message because you are subscribed to the Google Groups “ERPNext Technical Forum” group.
To view this discussion on the web visithttps://groups.google.com/d/msg/wnframework/-/L0CnUIoBiAYJ.
To post to this group, send email to wn...@googlegroups.com.
To unsubscribe from this group, send email to wnframework+un...@googlegroups.com.
For more options, visit this group athttp://groups.google.com/group/wnframework?hl=en.


Pratik Vyas
Twitter : @pdvyas

ERPNext - World’s most affordable ERP - (Rs 299 / $7 per user per month)
Website:https://www.erpnext.com


You received this message because you are subscribed to the Google Groups “ERPNext Technical Forum” group.
To post to this group, send email to wn...@googlegroups.com.
To unsubscribe from this group, send email to wnframework+un...@googlegroups.com.
For more options, visit this group athttp://groups.google.com/group/wnframework?hl=en.


You received this message because you are subscribed to the Google Groups “ERPNext Technical Forum” group.
To post to this group, send email to wn...@googlegroups.com.
To unsubscribe from this group, send email to wnframework+un...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/wnframework?hl=en.


You received this message because you are subscribed to the Google Groups “ERPNext Technical Forum” group.
To post to this group, send email to wn...@googlegroups.com.
To unsubscribe from this group, send email to wnframework+un...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/wnframework?hl=en.

FYI - I just checked, the new master has all tables in utf8

best,
Rushabh


-----------------------------------------------------
ERPNext - Business Operating System

W: https://erpnext.com
T: @rushabh_mehta

On 16-Mar-2012, at 1:51 AM, Pratik Vyas wrote:

Hey Anton,

Just run

sudo easy_install jinja2

on the terminal

--
Pratik Vyas
Twitter : @pdvyas

ERPNext - World's most affordable ERP - (Rs 299 / $7 per user per month)
Website: https://www.erpnext.com

On 16-Mar-2012, at 1:39 AM, AntonK wrote:

Pratik,

install script worked fine, then I modified defs.py and created
symlink in erpnext to wnframework, but in browser I get next message:
A problem occurred in a Python script. Here is the sequence of
function calls leading up to the error, in the order they occurred.
/home/akey/erpnext/index.cgi in ()
   70                 print webnotes.cms.index.get()
   71
   72 if __name__=="__main__":
   73         if init():
=>   74                 respond()
respond = <function respond>
/home/akey/erpnext/index.cgi in respond()
   68                 webnotes.handler.print_cookies()
   69                 print
=>   70                 print webnotes.cms.index.get()
   71
   72 if __name__=="__main__":
webnotes = <module 'webnotes' from 'lib/py/webnotes/__init__.pyc'>,
webnotes.cms = <module 'webnotes.cms' from 'lib/py/webnotes/cms/
__init__.py'>, webnotes.cms.index = <module 'webnotes.cms.index' from
'lib/py/webnotes/cms/index.py'>, webnotes.cms.index.get = <function
get>
/home/akey/erpnext/lib/py/webnotes/cms/index.py in get()
   53         """get index html"""
   54         import webnotes
=>   55         from jinja2 import Template
   56
   57         with open('lib/conf/index.html', 'r') as f:
jinja2 undefined, Template undefined

<type 'exceptions.ImportError'>: No module named jinja2
    args = ('No module named jinja2',)
    message = 'No module named jinja2'

On Mar 15, 10:51 pm, Pratik Vyas <pd...@gmail.com> wrote:
Hi,
On 16-Mar-2012, at 12:13 AM, AntonK wrote:

Hi,

Tried to install latest version, executed command:
python py/webnotes/install_lib/install.py root pass erpnextnew
but got an error:
_mysql_exceptions.ProgrammingError: (1146, "Table
'erpnextnew.tabDocType' doesn't exist")
although I see that table in mysql administrator gui in scheme
"erpnextnew".
What am I doing wrong?

Use the master.sql from erpnext project,

python py/webnotes/install_lib/install.py root pass erpnextnew -s path/to/erpnext/data/master.sql

You will have to inflate master.sql from master.sql.gz









On Mar 10, 2:31 pm, Pratik Vyas <pd...@erpnext.com> wrote:
On 10-Mar-2012, at 3:35 PM, Vivek wrote:

Hello ,

I just bumped into ERPNext today and thought it was amazing.
So without wasting time I wanted to get into the codes and more details

So now this is where I get confused.

The version I downloaded to review was ERPnext 1.0
The framework version was wnframework 1.7 I think ?

The version that I reviewed online was different
The framework version running this is different? 2.0?

I am guessing that you downloaded form erpnext-1.0.0.tar.gz fromhttp://erpnext.org. This tarball was built long ago.

I read on a blog that ERPNext is being re written from scratch and to continue support development of the old one is also being worked on . So 2 different branches.
Where can I can access these 2 branches?
Will the app work irrespective of the framework version?

True. Here are the links to the repositories (If you don't have/want_to install git, download the zip)

https://github.com/webnotes/wnframeworkhttps://github.com/webnotes/er...

Is there a blog / documentation were I could find a guide to all the tables ,relations etc
Is there a blog / documentation were I could find a guide to begin writing addon modules for ERPnext?

--
You received this message because you are subscribed to the Google Groups "ERPNext Technical Forum" group.
To view this discussion on the web visithttps://groups.google.com/d/msg/wnframework/-/L0CnUIoBiAYJ.
To post to this group, send email to wn...@googlegroups.com.
To unsubscribe from this group, send email to wnframework+un...@googlegroups.com.
For more options, visit this group athttp://groups.google.com/group/wnframework?hl=en.

--
Pratik Vyas
Twitter : @pdvyas

ERPNext - World's most affordable ERP - (Rs 299 / $7 per user per month)
Website:https://www.erpnext.com

--
You received this message because you are subscribed to the Google Groups "ERPNext Technical Forum" group.
To post to this group, send email to wn...@googlegroups.com.
To unsubscribe from this group, send email to wnframework+un...@googlegroups.com.
For more options, visit this group athttp://groups.google.com/group/wnframework?hl=en.

--
You received this message because you are subscribed to the Google Groups "ERPNext Technical Forum" group.
To post to this group, send email to wn...@googlegroups.com.
To unsubscribe from this group, send email to wnframework+un...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/wnframework?hl=en.


--
You received this message because you are subscribed to the Google Groups "ERPNext Technical Forum" group.
To post to this group, send email to wn...@googlegroups.com.
To unsubscribe from this group, send email to wnframework+un...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/wnframework?hl=en.




You received this message because you are subscribed to the Google Groups “ERPNext Technical Forum” group.

To post to this group, send email to wn...@googlegroups.com.

To unsubscribe from this group, send email to wnframework+un...@googlegroups.com.

For more options, visit this group at http://groups.google.com/group/wnframework?hl=en.

Pratik,

Done this but now I have just blank screen with menu, nowhere i can see initial setup as it was in installer version 1.0.0 (pfa screenshot)

On Friday, March 16, 2012 12:21:45 AM UTC+4, Pratik Vyas wrote:
Hey Anton,

Just run

sudo easy_install jinja2




You received this message because you are subscribed to the Google Groups “ERPNext Technical Forum” group.

To view this discussion on the web visit https://groups.google.com/d/msg/wnframework/-/ZLKI8V1f0QUJ.

To post to this group, send email to wn...@googlegroups.com.

To unsubscribe from this group, send email to wnframework+un...@googlegroups.com.

For more options, visit this group at http://groups.google.com/group/wnframework?hl=en.

Hi Anton,
Did you use the latest master.sql from the erpnext project ? Also check the modules_path in defs.py

You can also tally from the Wiki page Anand has made.

On 16-Mar-2012, at 10:23 PM, AntonK wrote:

Pratik,

Done this but now I have just blank screen with menu, nowhere i can see initial setup as it was in installer version 1.0.0 (pfa screenshot)

On Friday, March 16, 2012 12:21:45 AM UTC+4, Pratik Vyas wrote:
Hey Anton,
Just run

sudo easy_install jinja2


You received this message because you are subscribed to the Google Groups “ERPNext Technical Forum” group.
To view this discussion on the web visit https://groups.google.com/d/msg/wnframework/-/ZLKI8V1f0QUJ.
To post to this group, send email to wn...@googlegroups.com.
To unsubscribe from this group, send email to wnframework+un...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/wnframework?hl=en.
<Screenshot at 2012-03-16 20:51:36.png>


Pratik Vyas
Twitter : @pdvyas

ERPNext - World’s most affordable ERP - (Rs 299 / $7 per user per month)
Website: https://www.erpnext.com


You received this message because you are subscribed to the Google Groups “ERPNext Technical Forum” group.
To post to this group, send email to wn...@googlegroups.com.
To unsubscribe from this group, send email to wnframework+un...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/wnframework?hl=en.

Whats in your JS console?

-----------------------------------------------------
ERPNext - Business Operating System

W: https://erpnext.com
T: @rushabh_mehta

On 16-Mar-2012, at 10:23 PM, AntonK wrote:


Pratik,

Done this but now I have just blank screen with menu, nowhere i can see initial setup as it was in installer version 1.0.0 (pfa screenshot)

On Friday, March 16, 2012 12:21:45 AM UTC+4, Pratik Vyas wrote:
Hey Anton,

Just run

sudo easy_install jinja2













You received this message because you are subscribed to the Google Groups “ERPNext Technical Forum” group.

To view this discussion on the web visit https://groups.google.com/d/msg/wnframework/-/ZLKI8V1f0QUJ.

To post to this group, send email to wn…@googlegroups.com.

To unsubscribe from this group, send email to wnframework+un…@googlegroups.com.

For more options, visit this group at http://groups.google.com/group/wnframework?hl=en.

<Screenshot at 2012-03-16 20:51:36.png>




You received this message because you are subscribed to the Google Groups “ERPNext Technical Forum” group.

To post to this group, send email to wn...@googlegroups.com.

To unsubscribe from this group, send email to wnframework+un...@googlegroups.com.

For more options, visit this group at http://groups.google.com/group/wnframework?hl=en.

Console gives this:
Error: this.cp is undefined
Source File: http://localhost:8080/js/all-app.js
Line: 1400

On Friday, March 16, 2012 9:56:06 PM UTC+4, rushabh wrote:

Whats in your JS console?


-----------------------------------------------------
ERPNext - Business Operating System

W: https://erpnext.com



You received this message because you are subscribed to the Google Groups “ERPNext Technical Forum” group.

To view this discussion on the web visit https://groups.google.com/d/msg/wnframework/-/CWvLH5z0YXkJ.

To post to this group, send email to wn...@googlegroups.com.

To unsubscribe from this group, send email to wnframework+un...@googlegroups.com.

For more options, visit this group at http://groups.google.com/group/wnframework?hl=en.

Hi Anton,

Its hard to say, 

1. Are your file permissions okay?
2. Did you update the "modules_path" to the new erpnext folder

also have a look at http://localhost/webnotes/erpnext/?cmd=startup

Can you scan and see if you see an error traceback in it?

- Rushabh



-----------------------------------------------------
ERPNext - Business Operating System

W: https://erpnext.com
T: @rushabh_mehta

On 17-Mar-2012, at 12:45 AM, AntonK wrote:

Console gives this:
Error: this.cp is undefined
Source File: http://localhost:8080/js/all-app.js
Line: 1400

On Friday, March 16, 2012 9:56:06 PM UTC+4, rushabh wrote:
Whats in your JS console?

-----------------------------------------------------
ERPNext - Business Operating System

W: https://erpnext.com



You received this message because you are subscribed to the Google Groups “ERPNext Technical Forum” group.

To view this discussion on the web visit https://groups.google.com/d/msg/wnframework/-/CWvLH5z0YXkJ.

To post to this group, send email to wn…@googlegroups.com.

To unsubscribe from this group, send email to wnframework+un…@googlegroups.com.

For more options, visit this group at http://groups.google.com/group/wnframework?hl=en.




You received this message because you are subscribed to the Google Groups “ERPNext Technical Forum” group.

To post to this group, send email to wn...@googlegroups.com.

To unsubscribe from this group, send email to wnframework+un...@googlegroups.com.

For more options, visit this group at http://groups.google.com/group/wnframework?hl=en.

Rushabh,

1. permissions are ok I guess because all files checked out to my user’s home directory
2. module path updated, also it partially works as soon as I could see things like “Purchase Invoice” in Document>New dialog (although it gives errors in console “this.cp is undefined”, “wn.control_panel is undefined”).
Also I did not find any clues in startup command output (pfa textfile)

On Saturday, March 17, 2012 2:41:05 PM UTC+4, rushabh wrote:

Hi Anton,

Its hard to say, 

1. Are your file permissions okay?
2. Did you update the “modules_path” to the new erpnext folder


Can you scan and see if you see an error traceback in it?

- Rushabh





You received this message because you are subscribed to the Google Groups “ERPNext Technical Forum” group.

To view this discussion on the web visit https://groups.google.com/d/msg/wnframework/-/xzzfqEVAKUkJ.

To post to this group, send email to wn...@googlegroups.com.

To unsubscribe from this group, send email to wnframework+un...@googlegroups.com.

For more options, visit this group at http://groups.google.com/group/wnframework?hl=en.

Hi Anton,

Ok I think if you clear your cookies and try again it might work - Since you changed the database, you will have to change your cookies. 

I know its an issue - will fix it later.

best,
Rushabh



-----------------------------------------------------
ERPNext - Business Operating System

W: https://erpnext.com
T: @rushabh_mehta

On 17-Mar-2012, at 5:22 PM, AntonK wrote:

Rushabh,

1. permissions are ok I guess because all files checked out to my user's home directory
2. module path updated, also it partially works as soon as I could see things like "Purchase Invoice" in Document>New dialog (although it gives errors in console "this.cp is undefined", "wn.control_panel is undefined").
Also I did not find any clues in startup command output (pfa textfile)

On Saturday, March 17, 2012 2:41:05 PM UTC+4, rushabh wrote:
Hi Anton,

Its hard to say, 

1. Are your file permissions okay?
2. Did you update the "modules_path" to the new erpnext folder


Can you scan and see if you see an error traceback in it?

- Rushabh






You received this message because you are subscribed to the Google Groups “ERPNext Technical Forum” group.

To view this discussion on the web visit https://groups.google.com/d/msg/wnframework/-/xzzfqEVAKUkJ.

To post to this group, send email to wn…@googlegroups.com.

To unsubscribe from this group, send email to wnframework+un…@googlegroups.com.

For more options, visit this group at http://groups.google.com/group/wnframework?hl=en.

<startup_cmd.txt>




You received this message because you are subscribed to the Google Groups “ERPNext Technical Forum” group.

To post to this group, send email to wn...@googlegroups.com.

To unsubscribe from this group, send email to wnframework+un...@googlegroups.com.

For more options, visit this group at http://groups.google.com/group/wnframework?hl=en.

Hi Rushabh,
Now it works, thank you.

On Sunday, March 18, 2012 1:03:09 PM UTC+4, rushabh wrote:

Hi Anton,

Ok I think if you clear your cookies and try again it might work - Since you changed the database, you will have to change your cookies. 

I know its an issue - will fix it later.

best,
Rushabh




-----------------------------------------------------
ERPNext - Business Operating System

W: https://erpnext.com
T: @rushabh_mehta



You received this message because you are subscribed to the Google Groups “ERPNext Technical Forum” group.

To view this discussion on the web visit https://groups.google.com/d/msg/wnframework/-/-FbSRFpXjToJ.

To post to this group, send email to wn...@googlegroups.com.

To unsubscribe from this group, send email to wnframework+un...@googlegroups.com.

For more options, visit this group at http://groups.google.com/group/wnframework?hl=en.