Try ERPNext Buy Support Partners Foundation

Version-13 Docker Installation error

I’m facing a strange issue installing the develop version of erpnext on docker.
I successfully installed develop version on a base system(no virtualization).
However when I try to use the same steps in Docker I get the following error -
AttributeError: module ‘pandas’ has no attribute ‘core’

I used the same exact python version on the base system and Dockerfile - python 3.6.12.

Please advise.

I’ve worked around it by doing the following -
install libffi-dev
upgraded python to 3.8.6
Used the version-13-beta repo instead of development.

Develop branch is working on ‘Play with docker’

https://labs.play-with-docker.com/?stack=https://raw.githubusercontent.com/frappe/frappe_docker/develop/tests/pwd.yml

More about docker production: https://github.com/frappe/frappe_docker/blob/develop/README.md

Docker Development : https://github.com/frappe/frappe_docker/tree/develop/development