Ver 7.1.1 dropbox

what happened to dropbox integration it use to be here is this another undocumented feature:
Explore > Setup > Integrations > Dropbox Backup
I see I can manually create here but why go back:
explore > setup > integration service

1 Like

Hey all can we stop changing things without documenting the changes and worse hiding the once obvious?
By chance I put dropbox in search menu bar to troubleshoot a new install and what do you think I found “Dropbox Settings”
That of course led me to the need to manually add the key and secret to site_config.json a different step from the very prominent integration link that existed in the past version under “Integrations.”

These steps illuminated this great nugget below I am posting below so others can know about this…

Steps to enable dropbox backup service: 1. Create a dropbox app then get App Key and App Secret, https://www.dropbox.com/developers/apps

  1. Setup credentials on Dropbox Settings doctype. Click on Dropbox Settings top right corner

  2. After settings up App key and App Secret, generate access token Allow Dropbox Access

  3. After saving settings, Enable Dropbox Integration Service and Save a document.

After enabling service, system will take backup of files and database on daily or weekly basis as per set on Dropbox Settings page and upload it to your dropbox.

This is all well and good had I known that this document existed it did not come up in my forum search for dropbox so what I did was go to the sparsely published documentation and specifically the link below which has been my guide for previous version where there was no reference to the change hence my post:

https://frappe.github.io/erpnext/user/manual/en/setting-up/articles/setting-up-dropbox-backups

Thought this was working but I was wrong when I click take backup button here is the error:
Traceback (most recent call last):
File “/home/frappe/frappe-bench/apps/frappe/frappe/app.py”, line 55, in application
response = frappe.handler.handle()
File “/home/frappe/frappe-bench/apps/frappe/frappe/handler.py”, line 19, in handle
execute_cmd(cmd)
File “/home/frappe/frappe-bench/apps/frappe/frappe/handler.py”, line 30, in execute_cmd
method = get_attr(cmd)
File “/home/frappe/frappe-bench/apps/frappe/frappe/handler.py”, line 114, in get_attr
method = frappe.get_attr(cmd)
File “/home/frappe/frappe-bench/apps/frappe/frappe/init.py”, line 870, in get_attr
return getattr(get_module(modulename), methodname)
File “/home/frappe/frappe-bench/apps/frappe/frappe/init.py”, line 654, in get_module
return importlib.import_module(modulename)
File “/usr/lib64/python2.7/importlib/init.py”, line 37, in import_module
import(name)
ImportError: No module named dropbox_integration

1 Like

i agree 100% with the previous user on all of the points. would be nice at least to know what to expect, or what will break of these updates or changes.

I too have the same problem / error as above with the Dropbox backups / failing and also get the same error if i do Take Backup Now

please help

Hi @ermalc

It’s fixed via https://github.com/frappe/frappe/pull/2234

Kindly update the ERPNext, it will be OK.

Thanks…

ok here we go again went to bench update to “fix” and yet another issue please, please can we just get some consistency here and not push features to production that are not ready for primetime…

I must have reinstalled this product over 50 time wiping vms and reload just to get a product I can actually use:

frappe-bench]$ sudo bench update
INFO:bench.utils:updating bench
Already up-to-date.
remote: Counting objects: 110, done.
remote: Compressing objects: 100% (89/89), done.
remote: Total 110 (delta 56), reused 19 (delta 19), pack-reused 2
Receiving objects: 100% (110/110), 52.81 KiB | 0 bytes/s, done.
Resolving deltas: 100% (56/56), completed with 13 local objects.
From https://github.com/frappe/frappe
9f93076…d329ee3 master -> upstream/master
7c4f40b…9ecfebd develop -> upstream/develop
4f7a737…050e456 hotfix -> upstream/hotfix
fe98b32…657aa2d v7.0.x -> upstream/v7.0.x

  • [new tag] v7.1.3 -> v7.1.3
    Requirement already satisfied (use --upgrade to upgrade): Pillow in ./env/lib/python2.7/site-packages
    INFO:bench.app:pulling frappe
    From https://github.com/frappe/frappe
  • branch master -> FETCH_HEAD
    Updating 9f93076…d329ee3
    error: Your local changes to the following files would be overwritten by merge:
    frappe/init.py
    frappe/desk/doctype/bulk_update/bulk_update.js
    frappe/integration_broker/doctype/integration_service/integration_service.js
    frappe/integrations/doctype/dropbox_settings/dropbox_settings.js
    frappe/public/css/form_grid.css
    frappe/public/css/list.css
    frappe/public/less/form_grid.less
    frappe/public/less/list.less
    Please, commit your changes or stash them before you can merge.
    Aborting
    Traceback (most recent call last):
    File “/bin/bench”, line 11, in
    load_entry_point(‘bench’, ‘console_scripts’, ‘bench’)()
    File “/home/frappe/.bench/bench/cli.py”, line 40, in cli
    bench_command()
    File “/usr/lib64/python2.7/site-packages/click/core.py”, line 716, in call
    return self.main(*args, **kwargs)
    File “/usr/lib64/python2.7/site-packages/click/core.py”, line 696, in main
    rv = self.invoke(ctx)
    File “/usr/lib64/python2.7/site-packages/click/core.py”, line 1060, in invoke
    return _process_result(sub_ctx.command.invoke(sub_ctx))
    File “/usr/lib64/python2.7/site-packages/click/core.py”, line 889, in invoke
    return ctx.invoke(self.callback, **ctx.params)
    File “/usr/lib64/python2.7/site-packages/click/core.py”, line 534, in invoke
    return callback(*args, **kwargs)
    File “/home/frappe/.bench/bench/commands/update.py”, line 60, in update
    _update(pull, patch, build, bench, auto, restart_supervisor, requirements, no_backup, upgrade, force=force)
    File “/home/frappe/.bench/bench/commands/update.py”, line 76, in _update
    pull_all_apps(bench_path=bench_path)
    File “/home/frappe/.bench/bench/app.py”, line 140, in pull_all_apps
    remote=remote, branch=get_current_branch(app, bench_path=bench_path)), cwd=app_dir)
    File “/home/frappe/.bench/bench/utils.py”, line 127, in exec_cmd
    raise CommandFailedError(cmd)
    bench.utils.CommandFailedError: git pull upstream master

This is really troubling we have not attempted to customize anything we have just used the erpnext app to configure our site yet I had to stash both frappe and erpnext in apps to get bench update to work???

why is this happening not very conducive to have to jump through hoops everyday just to get a working application???

Having the same exact issue, error pops when trying to do update.

Since I had not customized anything yet I was able to do a “git stash” on apps/frappe and apps/erpnext. then bench update worked.
Take a look here on some suggestions that might help you.