V5.0 SMPT Confusion

Hi,
I’m using ERPNET 5.0 Version and have some confusion in SMPT sever setup.

I have attached pictures of both V4.0 and V5.0

In 4.0 there is clear fields for SMPT login details

http://imgur.com/em0xIJu

In V5.0 there is no option like that. Again I don’t want to use my POP3 email such as google, yahoo to send outbound email. I prefer to use mandrillapp or such SMPT services from ERPNext. This seems to have been removed from V5 ?

http://imgur.com/hKWiX1N

You can put any SMTP config there (ie. mandrill / Sendgrid). SMTP config is separate from POP3.

@pdvyas But where is the option for username and password for SMPT authentication ? Also sender email id field (SMPT email can be same for the entire company) ?

@pdvyas Any update on the SMTP settings ? Login name as password of the outgoing mail input is not present, without which SMTP server cannot be configured.

Hey, will check and reply.

This worked for me, http://i.imgur.com/1k27tBL.png

@pdvyas You are re-iterating what I said earlier. You are using inbound server settings for outbout server. Let me put it this way.

I want to send email as pdvyas@erpnext.com , use a mandrillapp (SMPT gateway) to send it
and registered user of mandrillapp is pdvyas@gmail.com , password: 12345

Generally SMPT Outgoing Configurations will be like below ( filled with demo credentials)
Send Email As: pdvyas@erpnext.com
SMPT Username:pdvyas@gmail.com ( or it can be pdvyas if that is username)
SMPT Password: 12345
SMPT Server: smtp.mandrillapp.com
SMPT Port: 587

Please tell me how can you achieve this in the outgoing server in V5 ?

@rmehta generally sends email from mandrillapp, talk to him once. SMPT server is nicely implemented in V4 or is it that in V5 Outbound SMPT Gateway servers are truncated ?

If you guys indeed decide to truncate a Outbound SMPT gateways, then it is big no no. Google, Yahoo doesn’t allow use of their SMPT gateways to send lot of emails. If the email is being generate from other web gateways, they will black list those sites.

If you are successful in configuring gmail setting in V5 and sent any email, you probably already got a waring message from google. Below is what I got

http://imgur.com/RjnHsjS

Below is the policing for using google SMTP.

https://support.google.com/mail/answer/14257?p=client_login&rd=1

All in all I strongly recommend to keep Full outbound server independent of inbound server settings.

Well you can do that by setting SMTP server address as mandrill and enter mandrill username and password in the section above it ( I agree the username and password field should not be in incoming email settings). Also set the email account as default)

@amruthp the benefit of using your own SMTP is that it will never go to spam.

If you are sending bulk mails, then you should use Mandrill. All transaction, automated emails go via the default email account, which could be Mandrill.

We will add an option in Newsletter to select the Email Account.

Thanks for testing V5 and your feedback!