v4 to v5 upgrade module

Hi,

i was creating a report from v4, and when upgrade it to v5 its gives error

Traceback (innermost last):
File “/home/sigma/frappe-bench/apps/frappe/frappe/app.py”, line 50, in application
response = frappe.handler.handle()
File “/home/sigma/frappe-bench/apps/frappe/frappe/handler.py”, line 62, in handle
execute_cmd(cmd)
File “/home/sigma/frappe-bench/apps/frappe/frappe/handler.py”, line 85, in execute_cmd
ret = frappe.call(method, **frappe.form_dict)
File “/home/sigma/frappe-bench/apps/frappe/frappe/init.py”, line 732, in call
return fn(*args, **newargs)
File “/home/sigma/frappe-bench/apps/frappe/frappe/desk/query_report.py”, line 87, in run
columns, result = frappe.get_attr(method_name)(frappe._dict(filters))
File “/home/sigma/frappe-bench/apps/frappe/frappe/init.py”, line 715, in get_attr
return getattr(get_module(modulename), methodname)
File “/home/sigma/frappe-bench/apps/frappe/frappe/init.py”, line 520, in get_module
return importlib.import_module(modulename)
File “/usr/lib/python2.7/importlib/init.py”, line 37, in import_module
import(name)
File “/home/sigma/frappe-bench/apps/erpnext/erpnext/accounts/report/cashflow/cashflow.py”, line 9, in
from erpnext.accounts.utils import (get_balance_on)
File “/home/sigma/frappe-bench/apps/erpnext/erpnext/accounts/utils.py”, line 10, in
import frappe.widgets.reportview

where its being changed ?

Check this from your custom report

ya i know its on my custom report…

its just the last line
File “/home/sigma/frappe-bench/apps/erpnext/erpnext/accounts/utils.py”, line 10, in
import frappe.widgets.reportview

but its fixed already …
referring to https://discuss.frappe.io/t/error-after-upgrade-to-v5/4967/3

1 Like