Try ERPNext Buy Support Partners Foundation

[v12] Modules don't show on desk

Hi,
I’m on v12 both frappe and erpnext.
For some users I don’t see for example HR card on desk. I can select show/hide cards and select HR (in other words it is visible in the show/hide pop-up), but it will not show on desk. I removed all custom permissions and also assigned all modules to this user, still nothing.

Any ideas?

Hi,

I am having a similar problem with v12. I hid some modules. If I activate them now through Show / Hide cards, they don’t show up in the deskview anymore.

Are more people having similar issues or both issues and solutions?

1 Like

Hello @nando, @bedo

Im facing the same problem, was there a solution to this?

Yeps guys, i also sometimes face this issue.
Unfortunately my solution is to create new user with same role as before :grimacing:.
Hope can find real solution here.

1 Like

I am having the same problem for the mean time i create new user with same rights… but im facing one more problem in workflow… some user are able to see the workflow button in form but some user with the same rights and permissions are not able to see the workflow button…

Is the Domain a module is bound to enabled?

Yes the enabled domains are “Services” and “Manufacturing” and all other user with having the same module access are able to see the modules except some users …

Any updates on this? We still see this happening from time to time when cards are hidden and then later added that they do not show up. Resetting the modules settings also seems to have no impact.

There seems to be a block_modules in field in User doctype. You could check in tabBlock Module or see the User doc for entries in block_modules field which is hidden, so check with js.

Thanks, I have checked the block modules and removed them, but still does not show up…

Go to the doctype and tick Cutome?

Any solution to this ??