Try ERPNext Buy Support Partners Foundation

V12.1.8: Table Multiselect field was erased/cleared after Save

As shown below, ‘Belongs to Company’ field is a table multiselect field I created in Customer doctype. Everytime when I save the customer, my selections in the field will be erased.

1 Like

Have you given it as select field type, check whether any custom script is written for that field.

Hi @Jenisha, it is Table MultiSelect field in the Customer doctype and the docfield’s “Option” is linked to “Company Multiselect Child Table” which is a child table doctype as shown below.

I have followed the instructions as per the guide: https://erpnext.com/docs/user/manual/en/customize-erpnext/articles/table-multiselect

No, I do not have any custom scripts for Customer doctype.

1 Like

I’m having the same issue. Did you solve it?

1 Like

This kind of behaviour is most likely due to a bug… I’d suggest you open a Github issue

Kind regards,

Unfortunately, no, I have not solve it yet.

Just reported: https://github.com/frappe/erpnext/issues/19673

You’re better off using this alternative:
https://github.com/frappe/frappe/pull/8832

please try to use my alternative solution and feedback whether it is okay,update the PR also

I solved this by ensuring that the field in the child table is marked as In Grid View.
@Raymond_Liew in your case you need to check In Grid View for Company in your Company Multiselect Child Table.

2 Likes

@marynvdl Thanks it worked for me also