Try ERPNext Buy Support Partners Foundation

User Permission not working in reports

Hi,
I have setup two companies, A & B. A is Parent and B is child of A.

Now I have setup user permission of a user to access only company B.

It works in great in every docType but when I open any sort of report Company filters doesn’t show any company in the dropdown, technically it should company B in this list.

P.S: Version is 12

1 Like

Inorder to make the hierarchy works, the user must have child and parent permissions at the same time.

Like
User A should have permissions of (Company Parent & Child A),
User B should have permissions of (Company Parent & Child B).

In this way user A can’t access Child B (company) and user B can’t access Child A (company).

1 Like

I have the same issue, but when user have permission of company parent, he/her an access another company also.
User A should have permissions of (Company Parent & Child A),
User B should have permissions of (Company Parent & Child B).

In this way user A can access Child B (company) and Child A (company).
@avaiskhatri can you help me user A can only access company child A in report.

Hello Avaiskhatri,
I have set user permission to one company under user permissions,
But when I try to see the general ledger reports no company showing


Also add the permission to the user like this
Accounts Manager,Account user,item manager,purchase manager,sales manager,
sales master manager,sales manager,sales user

Is it correct or not?

I have the same issue

Any one solved this??

go to system settings ==>select permission=>remove the check box of Apply Strict User Permissions it will solve your problem

still i can not see the company

In my case its working fine

if you set up on V12 will not work like that.

I am also use version 12 and its work fine for me

check the allow guest to upload file

1 Like

yeah you are right. it’s working now