Try ERPNext Buy Support Partners Foundation

Use only port 80 and 443, disable port 8000

Hello together,

I tried several tutorials and several methods to try and ONLY enable port 80 (with forwarding) and 443, effectively making ERPNext only available through SSL.

However, there is no way I can make it work to block port 8000.

Even when simply trying to change the Procfile for ERPNext to launch on port 80 does not work -> ERPNext won’t launch anymore.
Also, the command bench set-nginx-port does work, but it does not disable port 8000.

Does anyone have a hint for me?

Have you tried:

Well to make ERPNext only available using TLS/SSL you just have to make sure to reverse proxy it, with nginx, traefik, cady, apache, etc. And only expose to the outside where your reverse proxy listens at. If you’re configuring this correctly you shouldn’t worry that anyone on the outside can access ERPNext without TLS/SSL