Upgrade from v13 to v14

I tried to upgrade from ERPNext: v13.34.2 / Frappe Framework: v13.34.0 to v14 on my docker installation.

After the upgrade i can’t access the frontend any more (500 Internal server error).

I’m getting exceptions after doing this in my docker-based setup (with a lot of followup exceptions):

/home/frappe/frappe-bench/apps/frappe/frappe/database/query.py:197: UserWarning: The 'filters_config' hook used to add custom operators is not yet implemented in frappe.db.query engine. Use db_query (frappe.get_list) instead.
warn(
[2022-08-03 11:10:09 +0000] [9] [ERROR] Error handling request /
Traceback (most recent call last):
File "/home/frappe/frappe-bench/apps/frappe/frappe/website/serve.py", line 18, in get_response
response = renderer_instance.render() ...

Also duringbench migrate several exceptions occure, but continuing and reporting success at the end. However the UI keeps unaccesible with the same error.

Any suggestion how to solve?

1 Like

Any help or infor would be appreciated.

can you describe how did you do upgrade(commands)? I’m also having difficulties to upgrade, but I have errors with sql query.

Try commands from list, one after another:

  • bench migrate
  • bench switch-to-branch version-14 --upgrade
  • update --reset
  • bench restart

Did you install aditional apps like payments, hrms non_profit?

Thank you for your respond.
In ma docker installation i opened a console of the backend container and used the following commands:

bench --site testsite.lan set-config -p maintenance_mode 1
bench --site testsite.lan set-config -p pause_scheduler 1
bench --site testsite.lan migrate
bench --site testsite.lan set-config -p pause_scheduler 0
bench --site testsite.lan set-config -p maintenance_mode 0

The migrate command printed a punch of SQL error messages which i’m not sure if they are relevant or just because of not found tables or content.

The site in browser remains unaccesible with internal server errors (because of logged python errors on the backend container)
If i remove the asset volume and recreate this volume with the next start of v14 I can spin of the installation and until now seems to work well with all data available.

For the time being I managed to (potential) sucessful upgrade by

  • Ignoring the SQL error messages
  • removing the asset volume and let the next docker compuse up manage to recreate this volume

I’m not sure if ignoring and deleting/recreate asset volume is acceptible or if it will bring issues.

I did not run the switch-to-branch command - I will give it a try, if this prevents of the step to remove the asset volume

Try commands from list, one after another:

  • bench migrate
  • bench switch-to-branch version-14 --upgrade
  • update --reset
  • bench restart

Those commands are not applicable with a docker based installation

bench migrate wants a parameter --site set

All the next commands are not available in a docker based installation:
bench switch-to-branch version-14 --upgrade
update --reset
bench restart

also interessted in a solution to upgrade the docker containers