Updates via browser

One more thing needs you help. After launching updates from the frontend following errors occur:


error: cannot open .git/FETCH_HEAD: Permission denied

error: cannot open .git/FETCH_HEAD: Permission denied

Traceback (most recent call last):
File “lib/wnf.py”, line 501, in <module>
run()
File “lib/wnf.py”, line 410, in run
patch_sync_build()
File “lib/wnf.py”, line 82, in patch_sync_build
rebuild()
File “lib/wnf.py”, line 64, in rebuild
bundlejs.bundle(False)
File “/opt/erpnext/lib/webnotes/utils/bundlejs.py”, line 189, in bundle
bundle.make()
File “/opt/erpnext/lib/webnotes/utils/bundlejs.py”, line 115, in make
self.concat(infiles, os.path.relpath(os.path.join(self.path, outfile), os.curdir))
File “/opt/erpnext/lib/webnotes/utils/bundlejs.py”, line 81, in concat
with open(outfile, ‘w’) as f:
IOError: [Errno 13] Permission denied: u’public/js/report-legacy.min.js’

Building js and css files…



You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un...@googlegroups.com.

To post to this group, send email to er...@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msg/erpnext-developer-forum/-/r7QT-yhk5_kJ.

For more options, visit https://groups.google.com/groups/opt_out.

 

 

Hi Slava,

Please check this: https://github.com/webnotes/erpnext/wiki/How-to-Install-ERPNext#upgrade--run-latest-patches

You need to change owner of your install directory, its subdirectories and files to apache user, before you can use the update manager.

Thanks,
Anand.

On 04-May-2013, at 11:31 AM, Slava <as...@gmail.com> wrote:

One more thing needs you help. After launching updates from the frontend following errors occur:

error: cannot open .git/FETCH_HEAD: Permission denied

error: cannot open .git/FETCH_HEAD: Permission denied

Traceback (most recent call last):
File “lib/wnf.py”, line 501, in <module>
run()
File “lib/wnf.py”, line 410, in run
patch_sync_build()
File “lib/wnf.py”, line 82, in patch_sync_build
rebuild()
File “lib/wnf.py”, line 64, in rebuild
bundlejs.bundle(False)
File “/opt/erpnext/lib/webnotes/utils/bundlejs.py”, line 189, in bundle
bundle.make()
File “/opt/erpnext/lib/webnotes/utils/bundlejs.py”, line 115, in make
self.concat(infiles, os.path.relpath(os.path.join(self.path, outfile), os.curdir))
File “/opt/erpnext/lib/webnotes/utils/bundlejs.py”, line 81, in concat
with open(outfile, ‘w’) as f:
IOError: [Errno 13] Permission denied: u’public/js/report-legacy.min.js’

Building js and css files…




You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un…@googlegroups.com.

To post to this group, send email to er…@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msg/erpnext-developer-forum/-/r7QT-yhk5_kJ.

For more options, visit https://groups.google.com/groups/opt_out.

 

 




You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un...@googlegroups.com.

To post to this group, send email to er...@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.