Try ERPNext Buy Support Partners Foundation

Update from 9.1.4 to Current

My production ERPNext server is running ERPNext v9.1.4 (master) and Frappe Framework v9.1.6 (master). Running on Ubuntu Server. What is the best upgrade path to get it up to whatever the current version is? Are there any issues to be aware of?

I recommend that you upgrade to version 11 since version 12 is still on development.
For upgrade path I recommend that you install version 11 in another server then install your app there. If you have errors during installing your app then solve it one by one then document it properly. Then try to test your app in the version 11 if everything working. If everything is working then you can consider to upgrade your version 9 to 11 since you already know the expected errors and solutions