Update error from v8 to v10

trying to update from v8 to v10 and got this error -

“erpnext pyopenssl 17.5.0 has requirement cryptography>=2.1.4, but you’ll have cryptography 1.9 which is incompatible”

The site is stuck in updating

Any help will be appreciated.

In your frappe-bench folder execute this command.
./env/bin/pip install --upgrade cryptography

1 Like

Get this error on executing the above command -

You are using pip version 9.0.1, however version 10.0.0 is available.
You should consider upgrading via the ‘pip install --upgrade pip’ command.

However I’m already on 10 (confirmed by using pip -version)

Anyways I ran “bench update” again and this time a new error
requests 2.18.1 has requirement idna<2.6,>=2.5, but you’ll have idna 2.6 which is incompatible.

It’s a warning/ notice. Not an error. And the pip being refereed to in this case is ./env/bin/pip
To prevent seeing the message again, use
./env/bin/pip install --upgrade pip

1 Like

gives the following error on running that command again -

INFO:bench.utils:./env/bin/pip install --upgrade pip
Requirement already up-to-date: pip in ./env/lib/python2.7/site-packages (10.0.0)
requests 2.18.1 has requirement idna<2.6,>=2.5, but you’ll have idna 2.6 which is incompatible.
INFO:bench.utils:./env/bin/pip install -q -r /home/frappe/.bench/requirements.txt

Traceback (most recent call last):
File “/usr/local/bin/bench”, line 11, in
load_entry_point(‘bench’, ‘console_scripts’, ‘bench’)()
File “/home/frappe/.bench/bench/cli.py”, line 40, in cli
bench_command()
File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 722, in call
return self.main(*args, **kwargs)
File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 697, in main
rv = self.invoke(ctx)
File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 1066, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 895, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 535, in invoke
return callback(*args, **kwargs)
File “/home/frappe/.bench/bench/commands/update.py”, line 58, in update
_update(pull, patch, build, bench, auto, restart_supervisor, requirements, no_backup, force=force, reset=reset)
File “/home/frappe/.bench/bench/commands/update.py”, line 74, in _update
update_requirements(bench_path=bench_path)
File “/home/frappe/.bench/bench/utils.py”, line 418, in update_requirements
install_requirements(pip, bench_req_file)
File “/home/frappe/.bench/bench/utils.py”, line 486, in install_requirements
exec_cmd("{pip} install -q -r {req_file}".format(pip=pip, req_file=req_file))
File “/home/frappe/.bench/bench/utils.py”, line 153, in exec_cmd
raise CommandFailedError(cmd)
bench.utils.CommandFailedError: ./env/bin/pip install -q -r /home/frappe/.bench/requirements.txt

I’m not sure but it seems to be related to pip 10.


Regarding the 2nd traceback you posted above: run bench update.