Try ERPNext Try Frappe Cloud Buy Support Partners Foundation

Update ERPNext v12 to v13

Hey Everyone,

I hope you all fine and doing great. I want to update erpnext v12 to v13 and i used the command.
bench switch-to-branch version-13-beta frappe erpnext --upgrade
and it is switched to v13 successfully but the issue is when i run the command
bench update --upgrade

then it shows errors:

  1. UTF-8 Error
  2. Syntax Error: Invalid syntax error

so i can resolve this error if anyone have solution then please guide us.
Thanks for the time.

Regards,

May we know the operating environment?

Try bench console , and type: print (sys.version) . What is the result?

For erp update v12 to v13

1 Like

ref,

ref,

How about on Debain 9?

same method @rachanna

But it crashes because of some Python error. Do you suggest that first we should upgrade Debain9 to 10?

ok i will upload soon

Reinstall or upgrade to Debian 10 then Try from below link.

Thanks a lot, but I’ve v12 and I have to migrate from v12 to v13 while I’ve debain9. Please suggest.

have you tried ?


This is the issue, I think.

upgrade python env then try.

sudo apt-get install python3-dev
bench migrate-env python3
bench restart
bench update
bench migrate-env python3.6

Thanks a lot, it solved the issue with this. First I upgraded to Debain10 then migrated to latest version of Python and then lastly switched to v13.