Try ERPNext Buy Support Partners Foundation

UoM of raw material in BOM

Dear all,
I have faced with serious problem. When I made BOM, I can not define quantity in decimal number for raw material.
Example: I need 1 .3 meter of silk but the system alway round it to 1 meter.
I also check condition “Whole number” in UoM setting. It is not checked.
Please help me in this problem, anyone have any solution for this problem. Because in manufacturing, we need more decimal quantity for material.

Thanks and best regards,

Under settings, change the number of decimals that your system uses. Alternatively, create a cm/mm unit and specify 130cm/1300mm



Dear @trentmu , I already setup 3 decimal number in system setting, but it is not work.
Alternatively, we can use smaller unit, but it is so inconvenience as square foot or another unit.
Are there any way to solve? Is it a bug of the system. when the function " whole number " not work.

hello dear,
please show me the BOM setup screen shot.


And BOM , I dont have any setting for it

Anyone else can help me?

Did you try , and . ? Like 1.9 and 1,9 ?

Already tried.
But it’s not work.
1 case it’s rounded ( I input 1.9 and it returns 2)
and another case, ( Input 1,9 and it return 19)
@TurkerTunali

It seems “Whole Number” or “Float Precision” issue. Try it with different UoM or create a new UoM. Also there should be 2 settings for Float Precision. One of them is in the System Settings and there should be another Float Precision setting.

I already tried but not work.
I think it should be fix soon
Thanks and best regards,

Did you check the following ?
Customize Form - BOM Item - Qty - Line Detail - Precision
Set the precision as 2.

Dear @TurkerTunali
Already set up as your instruction but not work .


do you have any way to setup here?
Thanks a lot

It is really strange. Do you have any warning or error in the browser console?

Dear @TurkerTunali,
No warning, no error,
When I put 1.3 it return 13
and 1,3 it return 1