Understanding totals with report filters

I created a Pending Invoice summary using report builder.
This is used to send summary of invoices for reconciliation at the end of a period.
However it shows a random extra line row 12 without any invoice number
Also the “show total” row 13 is messed up.

This is repeated with all customers

I created another report from scratch. Turns out the row 12 is total. (which is wrong anyway)
Observation : row 13 is twice of row 12
There seems to be some error in show total logic.

Did you add a totals row?

@rmehta totals row is row 13 in the screenshot above.
However in the “new” report row 12 is totals row.

Json for report ->
{“add_total_row”: 0, “sort_by”: “Sales Invoice.customer_name”, “add_totals_row”: 0, “sort_order”: “asc”, “sort_by_next”: null, “filters”: [[“Sales Invoice”, “status”, “!=”, “Draft”], [“Sales Invoice”, “status”, “!=”, “Cancelled”], [“Sales Invoice”, “status”, “!=”, “Paid”], [“Sales Invoice”, “customer”, “=”, “Kitchen Life Time”]], “sort_order_next”: “desc”, “columns”: [[“customer_name”, “Sales Invoice”], [“name”, “Sales Invoice”], [“item_name”, “Sales Invoice Item”], [“qty”, “Sales Invoice Item”], [“price_list_rate”, “Sales Invoice Item”], [“discount_percentage”, “Sales Invoice Item”], [“net_rate”, “Sales Invoice Item”], [“net_amount”, “Sales Invoice Item”], [“total_taxes_and_charges”, “Sales Invoice”], [“grand_total”, “Sales Invoice”]]}

Row 12 showing even when add total row is unticked

Looks weird, can you post this on GitHub and tag it as “bug”


Not able to label as bug.