Try ERPNext Buy Support Partners Foundation

Unable to update v12 to v13

sudo bench switch-to-branch develop frappe erpnext --upgrade

is not working properly.

/home/frappe/frappe-bench# bench version
erpnext 12.10.0
foundation 0.0.1
frappe 12.7.0

OS: Ubuntu 16.04

I have tried this and achieve.

36%20PM%20-%20Edited

  • sudo bench switch-to-branch version-13-beta frappe erpnext --upgrade
  • sudo bench update --patch
  • sudo bench setup requirements
  • sudo npm cache clean -f
  • sudo npm install -g n
  • sudo n stable
  • sudo bench setup requirements
  • sudo bench --site <my site> migrate

@Suresh_Thakor thanks for the quick response? What was your OS version ?

This is how I Updated to v13 finally:

on v12

bench update

Export database and make a zip of of private and public files.

Created another server using Ubuntu 18.04
Installed frappe, erpnext with version 12 & [custom apps]

Import database and move all private and public files to relevant folders.

Later then updated to v13 using the following command:

bench switch-to-branch version-13-beta frappe erpnext --upgrade

Sorry for late reply. It is Debian 10, also running fine in Ubuntu 18.04.

1 Like

Hellow @Suresh_Thakor, Am getting this error on running sudo bench update --patch

Restart the server and try again.
also check file permissions.

sudo chown -R frappe:frappe *

I have restarted but still the same error.

Then on a different server, we have this error persistent

Error 13-Permission Denied

Did you tried this command ?

Have you installed frappe-bench for other user and not for frappe user?
May be that’s the reason it is failing?

Yes I tried this.

I have installed ERPnext for Frappe user

You might have supervisor running as root user instead of frappe user. Try running the command with sudo manually after this to see if that works.

Seems like ERPNext isn’t installed on your bench env. Run ./env/bin/pip install -e ./apps/erpnext and try again.

Erpnext was actually running. I have been using the server for almost two years … I was only upgrading from V12 to 13. I am getting the below error after running the command.

root@vmi225827:~# su frappe
frappe@vmi225827:/root$ ./env/bin/pip install -e ./apps/erpnext
bash: ./env/bin/pip: Permission denied
frappe@vmi225827:/root$ sudo ./env/bin/pip install -e ./apps/erpnext
[sudo] password for frappe:
sudo: ./env/bin/pip: command not found
frappe@vmi225827:/root$ sudo ./env/bin/pip3 install -e ./apps/erpnext
[sudo] password for frappe:
sudo: ./env/bin/pip3: command not found