ERPNext.com Frappe Cloud Support Partners Foundation Frappe School

Unable to uncheck 'custom' checkbox for new doctype in version frappe 13.9.1

We are looking to develop a custom-app with new doctypes.

The ‘custom’ checkbox for new doctypes for Administrator user isn’t enabled even after 1) developer_mode is set to 1 in site_config.json for site site1.local 2) bench clear-cache 3) nginx server is restarted 4) bench restart.

It should be uncheckable for generating .js and .py files on the ‘custom app’.

Following are entries in site_config.json:
"developer_mode": 1, "server_script_enabled": true

My server is a production replica running frappe13.9.1/erpnext13.9.2. Enabling developer_mode shouldn’t be a problem either in production or any other as mentioned here https://discuss.erpnext.com/t/developer-mode-and-production-mode/9445/2.

However im able to uncheck the ‘custom’ checkbox for my local virtual-machine running frappe12.13.0/erpnext 12.16.2.

Could someone pls throw some light on what might be the problem. Is it a bug / version issue? Anyone who got the checkbox uncheckable for version 13 ?

Turned out it wasn’t really the ‘Administrator’ account (mentioned here)i was trying with. ‘Administrator’ account is the one created while installing ERPNext.

Silly of me to assume that any account with all roles selected and permission for all seen doctypes was also an Administrator account.