Try ERPNext Buy Support Partners Foundation

Unable to run bench start command

i am newbie to erpnext, using Ubuntu 20.04.1 LTS
i could not found the main problem with installation i am running bench start command and this is the output i am getting.

WARN: bench is installed in editable mode!

This is not the recommended mode of installation for production. Instead, install the package from PyPI with: pip install frappe-bench

/usr/lib/python3.8/subprocess.py:844: RuntimeWarning: line buffering (buffering=1) isn’t supported in binary mode, the default buffer size will be used
self.stdout = io.open(c2pread, ‘rb’, bufsize)
/usr/lib/python3.8/subprocess.py:844: RuntimeWarning: line buffering (buffering=1) isn’t supported in binary mode, the default buffer size will be used
self.stdout = io.open(c2pread, ‘rb’, bufsize)
/usr/lib/python3.8/subprocess.py:844: RuntimeWarning: line buffering (buffering=1) isn’t supported in binary mode, the default buffer size will be used
self.stdout = io.open(c2pread, ‘rb’, bufsize)
/usr/lib/python3.8/subprocess.py:844: RuntimeWarning: line buffering (buffering=1) isn’t supported in binary mode, the default buffer size will be used
self.stdout = io.open(c2pread, ‘rb’, bufsize)
/usr/lib/python3.8/subprocess.py:844: RuntimeWarning: line buffering (buffering=1) isn’t supported in binary mode, the default buffer size will be used
self.stdout = io.open(c2pread, ‘rb’, bufsize)
/usr/lib/python3.8/subprocess.py:844: RuntimeWarning: line buffering (buffering=1) isn’t supported in binary mode, the default buffer size will be used
self.stdout = io.open(c2pread, ‘rb’, bufsize)
/usr/lib/python3.8/subprocess.py:844: RuntimeWarning: line buffering (buffering=1) isn’t supported in binary mode, the default buffer size will be used
self.stdout = io.open(c2pread, ‘rb’, bufsize)
/usr/lib/python3.8/subprocess.py:844: RuntimeWarning: line buffering (buffering=1) isn’t supported in binary mode, the default buffer size will be used
self.stdout = io.open(c2pread, ‘rb’, bufsize)
18:06:26 system | redis_cache.1 started (pid=109888)
18:06:26 system | redis_socketio.1 started (pid=109890)
18:06:26 redis_cache.1 | 109891:C 15 Sep 2020 18:06:26.648 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
18:06:26 redis_cache.1 | 109891:C 15 Sep 2020 18:06:26.648 # Redis version=5.0.7, bits=64, commit=00000000, modified=0, pid=109891, just started
18:06:26 redis_cache.1 | 109891:C 15 Sep 2020 18:06:26.648 # Configuration loaded
18:06:26 redis_socketio.1 | 109895:C 15 Sep 2020 18:06:26.648 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
18:06:26 redis_socketio.1 | 109895:C 15 Sep 2020 18:06:26.648 # Redis version=5.0.7, bits=64, commit=00000000, modified=0, pid=109895, just started
18:06:26 redis_socketio.1 | 109895:C 15 Sep 2020 18:06:26.648 # Configuration loaded
18:06:26 redis_socketio.1 | 109895:M 15 Sep 2020 18:06:26.649 * Increased maximum number of open files to 10032 (it was originally set to 1024).
18:06:26 redis_socketio.1 | 109895:M 15 Sep 2020 18:06:26.649 * Running mode=standalone, port=12000.
18:06:26 redis_socketio.1 | 109895:M 15 Sep 2020 18:06:26.649 # Server initialized
18:06:26 redis_socketio.1 | 109895:M 15 Sep 2020 18:06:26.649 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
18:06:26 redis_socketio.1 | 109895:M 15 Sep 2020 18:06:26.649 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
18:06:26 redis_cache.1 | 109891:M 15 Sep 2020 18:06:26.648 * Increased maximum number of open files to 10032 (it was originally set to 1024).
18:06:26 redis_cache.1 | 109891:M 15 Sep 2020 18:06:26.649 * Running mode=standalone, port=13000.
18:06:26 redis_cache.1 | 109891:M 15 Sep 2020 18:06:26.649 # Server initialized
18:06:26 redis_cache.1 | 109891:M 15 Sep 2020 18:06:26.649 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
/usr/lib/python3.8/subprocess.py:844: RuntimeWarning: line buffering (buffering=1) isn’t supported in binary mode, the default buffer size will be used
self.stdout = io.open(c2pread, ‘rb’, bufsize)
18:06:26 redis_cache.1 | 109891:M 15 Sep 2020 18:06:26.649 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
18:06:26 redis_cache.1 | 109891:M 15 Sep 2020 18:06:26.649 * Ready to accept connections
18:06:26 redis_socketio.1 | 109895:M 15 Sep 2020 18:06:26.649 * Ready to accept connections
/usr/lib/python3.8/subprocess.py:844: RuntimeWarning: line buffering (buffering=1) isn’t supported in binary mode, the default buffer size will be used
self.stdout = io.open(c2pread, ‘rb’, bufsize)
18:06:26 system | redis_queue.1 started (pid=109894)
18:06:26 redis_queue.1 | 109899:C 15 Sep 2020 18:06:26.650 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
18:06:26 redis_queue.1 | 109899:C 15 Sep 2020 18:06:26.650 # Redis version=5.0.7, bits=64, commit=00000000, modified=0, pid=109899, just started
18:06:26 redis_queue.1 | 109899:C 15 Sep 2020 18:06:26.650 # Configuration loaded
18:06:26 redis_queue.1 | 109899:M 15 Sep 2020 18:06:26.650 * Increased maximum number of open files to 10032 (it was originally set to 1024).
18:06:26 system | watch.1 started (pid=109902)
18:06:26 redis_queue.1 | 109899:M 15 Sep 2020 18:06:26.651 * Running mode=standalone, port=11000.
18:06:26 redis_queue.1 | 109899:M 15 Sep 2020 18:06:26.651 # Server initialized
18:06:26 redis_queue.1 | 109899:M 15 Sep 2020 18:06:26.651 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
18:06:26 redis_queue.1 | 109899:M 15 Sep 2020 18:06:26.651 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
18:06:26 redis_queue.1 | 109899:M 15 Sep 2020 18:06:26.651 * Ready to accept connections
18:06:26 system | worker_short.1 started (pid=109914)
18:06:26 system | web.1 started (pid=109915)
18:06:26 system | worker_long.1 started (pid=109922)
18:06:26 system | worker_default.1 started (pid=109923)
18:06:26 system | socketio.1 started (pid=109905)
18:06:26 system | schedule.1 started (pid=109904)
18:06:26 socketio.1 | listening on *: 9000
18:06:27 schedule.1 | WARN: bench is installed in editable mode!
18:06:27 schedule.1 |
18:06:27 schedule.1 | This is not the recommended mode of installation for production. Instead, install the package from PyPI with: pip install frappe-bench
18:06:27 schedule.1 |
18:06:27 watch.1 | WARN: bench is installed in editable mode!
18:06:27 watch.1 |
18:06:27 watch.1 | This is not the recommended mode of installation for production. Instead, install the package from PyPI with: pip install frappe-bench
18:06:27 watch.1 |
18:06:27 web.1 | WARN: bench is installed in editable mode!
18:06:27 web.1 |
18:06:27 web.1 | This is not the recommended mode of installation for production. Instead, install the package from PyPI with: pip install frappe-bench
18:06:27 web.1 |
18:06:28 web.1 | Traceback (most recent call last):
18:06:28 web.1 | File “/usr/lib/python3.8/runpy.py”, line 193, in _run_module_as_main
18:06:28 web.1 | return _run_code(code, main_globals, None,
18:06:28 web.1 | File “/usr/lib/python3.8/runpy.py”, line 86, in _run_code
18:06:28 web.1 | exec(code, run_globals)
18:06:28 web.1 | File “/home/frappe/frappe-bench/apps/frappe/frappe/utils/bench_helper.py”, line 99, in
18:06:28 web.1 | main()
18:06:28 web.1 | File “/home/frappe/frappe-bench/apps/frappe/frappe/utils/bench_helper.py”, line 18, in main
18:06:28 web.1 | click.Group(commands=commands)(prog_name=‘bench’)
18:06:28 web.1 | File “/home/frappe/frappe-bench/env/lib/python3.8/site-packages/click/core.py”, line 764, in call
18:06:28 web.1 | return self.main(*args, **kwargs)
18:06:28 web.1 | File “/home/frappe/frappe-bench/env/lib/python3.8/site-packages/click/core.py”, line 717, in main
18:06:28 web.1 | rv = self.invoke(ctx)
18:06:28 web.1 | File “/home/frappe/frappe-bench/env/lib/python3.8/site-packages/click/core.py”, line 1137, in invoke
18:06:28 web.1 | return _process_result(sub_ctx.command.invoke(sub_ctx))
18:06:28 web.1 | File “/home/frappe/frappe-bench/env/lib/python3.8/site-packages/click/core.py”, line 1137, in invoke
18:06:28 web.1 | return _process_result(sub_ctx.command.invoke(sub_ctx))
18:06:28 web.1 | File “/home/frappe/frappe-bench/env/lib/python3.8/site-packages/click/core.py”, line 956, in invoke
18:06:28 web.1 | return ctx.invoke(self.callback, **ctx.params)
18:06:28 web.1 | File “/home/frappe/frappe-bench/env/lib/python3.8/site-packages/click/core.py”, line 555, in invoke
18:06:28 web.1 | return callback(*args, **kwargs)
18:06:28 web.1 | File “/home/frappe/frappe-bench/env/lib/python3.8/site-packages/click/decorators.py”, line 17, in new_func
18:06:28 web.1 | return f(get_current_context(), *args, **kwargs)
18:06:28 web.1 | File “/home/frappe/frappe-bench/apps/frappe/frappe/commands/init.py”, line 26, in _func
18:06:28 web.1 | ret = f(frappe._dict(ctx.obj), *args, **kwargs)
18:06:28 web.1 | File “/home/frappe/frappe-bench/apps/frappe/frappe/commands/utils.py”, line 570, in serve
18:06:28 web.1 | frappe.app.serve(port=port, profile=profile, no_reload=no_reload, no_threading=no_threading, site=site, sites_path=’.’)
18:06:28 web.1 | File “/home/frappe/frappe-bench/apps/frappe/frappe/app.py”, line 255, in serve
18:06:28 web.1 | run_simple(‘0.0.0.0’, int(port), application,
18:06:28 web.1 | File “/home/frappe/frappe-bench/env/lib/python3.8/site-packages/werkzeug/serving.py”, line 990, in run_simple
18:06:28 web.1 | s.bind(server_address)
18:06:28 web.1 | OSError: [Errno 98] Address already in use
18:06:28 system | web.1 stopped (rc=1)
18:06:28 system | sending SIGTERM to redis_cache.1 (pid 109888)
18:06:28 system | sending SIGTERM to redis_socketio.1 (pid 109890)
18:06:28 system | sending SIGTERM to redis_queue.1 (pid 109894)
18:06:28 system | sending SIGTERM to socketio.1 (pid 109905)
18:06:28 system | sending SIGTERM to watch.1 (pid 109902)
18:06:28 system | sending SIGTERM to schedule.1 (pid 109904)
18:06:28 system | sending SIGTERM to worker_short.1 (pid 109914)
18:06:28 system | sending SIGTERM to worker_long.1 (pid 109922)
18:06:28 system | sending SIGTERM to worker_default.1 (pid 109923)
18:06:28 redis_cache.1 | 109891:signal-handler (1600175188) Received SIGTERM scheduling shutdown…
18:06:28 redis_queue.1 | 109899:signal-handler (1600175188) Received SIGTERM scheduling shutdown…
18:06:28 system | worker_default.1 stopped (rc=-15)
18:06:28 redis_socketio.1 | 109895:signal-handler (1600175188) Received SIGTERM scheduling shutdown…
18:06:28 system | worker_long.1 stopped (rc=-15)
18:06:28 system | worker_short.1 stopped (rc=-15)
18:06:28 system | watch.1 stopped (rc=-15)
18:06:28 system | socketio.1 stopped (rc=-15)
18:06:28 system | schedule.1 stopped (rc=-15)
18:06:28 redis_cache.1 | 109891:M 15 Sep 2020 18:06:28.152 # User requested shutdown…
18:06:28 redis_cache.1 | 109891:M 15 Sep 2020 18:06:28.152 * Removing the pid file.
18:06:28 redis_cache.1 | 109891:M 15 Sep 2020 18:06:28.152 # Redis is now ready to exit, bye bye…
18:06:28 redis_queue.1 | 109899:M 15 Sep 2020 18:06:28.152 # User requested shutdown…
18:06:28 redis_queue.1 | 109899:M 15 Sep 2020 18:06:28.153 * Removing the pid file.
18:06:28 redis_queue.1 | 109899:M 15 Sep 2020 18:06:28.153 # Redis is now ready to exit, bye bye…
18:06:28 system | redis_cache.1 stopped (rc=-15)
18:06:28 system | redis_queue.1 stopped (rc=-15)
18:06:28 redis_socketio.1 | 109895:M 15 Sep 2020 18:06:28.156 # User requested shutdown…
18:06:28 redis_socketio.1 | 109895:M 15 Sep 2020 18:06:28.156 * Removing the pid file.
18:06:28 redis_socketio.1 | 109895:M 15 Sep 2020 18:06:28.156 # Redis is now ready to exit, bye bye…
18:06:28 system | redis_socketio.1 stopped (rc=-15)

can anyone tell me what is the issue with this.

18:06:28 web.1 | OSError: [Errno 98] Address already in use

how to fix this??

i have installed everything again now i am getting this error
ERROR: [Errno 2] No such file or directory: ‘run’

and here is the detailed output of bench start

WARN: bench is installed in editable mode!

This is not the recommended mode of installation for production. Instead, install the package from PyPI with: pip install frappe-bench

HEY! USE SCREEN frappe@AMAR-laptop:~/erpnext$ bench start
WARN: bench is installed in editable mode!

This is not the recommended mode of installation for production. Instead, install the package from PyPI with: pip install frappe-bench

/usr/lib/python3.8/subprocess.py:844: RuntimeWarning: line buffering (buffering=1) isn’t supported in binary mode, the default buffer size will be used
self.stdout = io.open(c2pread, ‘rb’, bufsize)
/usr/lib/python3.8/subprocess.py:844: RuntimeWarning: line buffering (buffering=1) isn’t supported in binary mode, the default buffer size will be used
self.stdout = io.open(c2pread, ‘rb’, bufsize)
/usr/lib/python3.8/subprocess.py:844: RuntimeWarning: line buffering (buffering=1) isn’t supported in binary mode, the default buffer size will be used
self.stdout = io.open(c2pread, ‘rb’, bufsize)
/usr/lib/python3.8/subprocess.py:844: RuntimeWarning: line buffering (buffering=1) isn’t supported in binary mode, the default buffer size will be used
self.stdout = io.open(c2pread, ‘rb’, bufsize)
/usr/lib/python3.8/subprocess.py:844: RuntimeWarning: line buffering (buffering=1) isn’t supported in binary mode, the default buffer size will be used
self.stdout = io.open(c2pread, ‘rb’, bufsize)
/usr/lib/python3.8/subprocess.py:844: RuntimeWarning: line buffering (buffering=1) isn’t supported in binary mode, the default buffer size will be used
self.stdout = io.open(c2pread, ‘rb’, bufsize)
/usr/lib/python3.8/subprocess.py:844: RuntimeWarning: line buffering (buffering=1) isn’t supported in binary mode, the default buffer size will be used
self.stdout = io.open(c2pread, ‘rb’, bufsize)
/usr/lib/python3.8/subprocess.py:844: RuntimeWarning: line buffering (buffering=1) isn’t supported in binary mode, the default buffer size will be used
self.stdout = io.open(c2pread, ‘rb’, bufsize)
20:20:56 system | redis_socketio.1 started (pid=115098)
20:20:56 system | redis_queue.1 started (pid=115102)
20:20:56 system | redis_cache.1 started (pid=115096)
20:20:56 redis_cache.1 | 115099:C 15 Sep 2020 20:20:56.593 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
20:20:56 redis_cache.1 | 115099:C 15 Sep 2020 20:20:56.593 # Redis version=5.0.7, bits=64, commit=00000000, modified=0, pid=115099, just started
20:20:56 redis_cache.1 | 115099:C 15 Sep 2020 20:20:56.593 # Configuration loaded
20:20:56 redis_cache.1 | 115099:M 15 Sep 2020 20:20:56.595 * Increased maximum number of open files to 10032 (it was originally set to 1024).
20:20:56 redis_socketio.1 | 115103:C 15 Sep 2020 20:20:56.596 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
/usr/lib/python3.8/subprocess.py:844: RuntimeWarning: line buffering (buffering=1) isn’t supported in binary mode, the default buffer size will be used
self.stdout = io.open(c2pread, ‘rb’, bufsize)
20:20:56 redis_socketio.1 | 115103:C 15 Sep 2020 20:20:56.596 # Redis version=5.0.7, bits=64, commit=00000000, modified=0, pid=115103, just started
20:20:56 redis_socketio.1 | 115103:C 15 Sep 2020 20:20:56.596 # Configuration loaded
20:20:56 redis_cache.1 | 115099:M 15 Sep 2020 20:20:56.596 * Running mode=standalone, port=13001.
20:20:56 redis_cache.1 | 115099:M 15 Sep 2020 20:20:56.596 # Server initialized
20:20:56 redis_cache.1 | 115099:M 15 Sep 2020 20:20:56.596 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
/usr/lib/python3.8/subprocess.py:844: RuntimeWarning: line buffering (buffering=1) isn’t supported in binary mode, the default buffer size will be used
self.stdout = io.open(c2pread, ‘rb’, bufsize)
20:20:56 redis_cache.1 | 115099:M 15 Sep 2020 20:20:56.596 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
20:20:56 redis_cache.1 | 115099:M 15 Sep 2020 20:20:56.596 * Ready to accept connections
20:20:56 system | socketio.1 started (pid=115109)
20:20:56 redis_socketio.1 | 115103:M 15 Sep 2020 20:20:56.597 * Increased maximum number of open files to 10032 (it was originally set to 1024).
20:20:56 redis_socketio.1 | 115103:M 15 Sep 2020 20:20:56.598 * Running mode=standalone, port=12001.
20:20:56 redis_socketio.1 | 115103:M 15 Sep 2020 20:20:56.598 # Server initialized
20:20:56 redis_socketio.1 | 115103:M 15 Sep 2020 20:20:56.598 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
20:20:56 redis_socketio.1 | 115103:M 15 Sep 2020 20:20:56.598 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
20:20:56 redis_socketio.1 | 115103:M 15 Sep 2020 20:20:56.598 * Ready to accept connections
20:20:56 system | watch.1 started (pid=115113)
20:20:56 redis_queue.1 | 115106:C 15 Sep 2020 20:20:56.598 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
20:20:56 redis_queue.1 | 115106:C 15 Sep 2020 20:20:56.598 # Redis version=5.0.7, bits=64, commit=00000000, modified=0, pid=115106, just started
20:20:56 redis_queue.1 | 115106:C 15 Sep 2020 20:20:56.598 # Configuration loaded
20:20:56 redis_queue.1 | 115106:M 15 Sep 2020 20:20:56.600 * Increased maximum number of open files to 10032 (it was originally set to 1024).
20:20:56 system | web.1 started (pid=115111)
20:20:56 redis_queue.1 | 115106:M 15 Sep 2020 20:20:56.601 * Running mode=standalone, port=11001.
20:20:56 redis_queue.1 | 115106:M 15 Sep 2020 20:20:56.601 # Server initialized
20:20:56 redis_queue.1 | 115106:M 15 Sep 2020 20:20:56.602 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
20:20:56 redis_queue.1 | 115106:M 15 Sep 2020 20:20:56.602 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
20:20:56 redis_queue.1 | 115106:M 15 Sep 2020 20:20:56.602 * Ready to accept connections
20:20:56 system | schedule.1 started (pid=115114)
20:20:56 system | worker_default.1 started (pid=115134)
20:20:56 system | worker_short.1 started (pid=115120)
20:20:56 system | worker_long.1 started (pid=115133)
20:20:57 socketio.1 | listening on *: 9001
20:20:57 web.1 | WARN: bench is installed in editable mode!
20:20:57 web.1 |
20:20:57 web.1 | This is not the recommended mode of installation for production. Instead, install the package from PyPI with: pip install frappe-bench
20:20:57 web.1 |
20:20:57 schedule.1 | WARN: bench is installed in editable mode!
20:20:57 schedule.1 |
20:20:57 schedule.1 | This is not the recommended mode of installation for production. Instead, install the package from PyPI with: pip install frappe-bench
20:20:57 schedule.1 |
20:20:57 watch.1 | WARN: bench is installed in editable mode!
20:20:57 watch.1 |
20:20:57 watch.1 | This is not the recommended mode of installation for production. Instead, install the package from PyPI with: pip install frappe-bench
20:20:57 watch.1 |
20:20:59 web.1 | * Running on http://0.0.0.0:8001/ (Press CTRL+C to quit)
20:20:59 web.1 | * Restarting with inotify reloader
20:20:59 watch.1 | Parsing scenario file run
20:20:59 watch.1 | ERROR: [Errno 2] No such file or directory: ‘run’
20:20:59 system | watch.1 stopped (rc=0)
20:20:59 system | sending SIGTERM to redis_cache.1 (pid 115096)
20:20:59 system | sending SIGTERM to redis_socketio.1 (pid 115098)
20:20:59 system | sending SIGTERM to redis_queue.1 (pid 115102)
20:20:59 system | sending SIGTERM to web.1 (pid 115111)
20:20:59 system | sending SIGTERM to socketio.1 (pid 115109)
20:20:59 system | sending SIGTERM to schedule.1 (pid 115114)
20:20:59 system | sending SIGTERM to worker_short.1 (pid 115120)
20:20:59 system | sending SIGTERM to worker_long.1 (pid 115133)
20:20:59 system | sending SIGTERM to worker_default.1 (pid 115134)
20:20:59 redis_socketio.1 | 115103:signal-handler (1600183259) Received SIGTERM scheduling shutdown…
20:20:59 redis_queue.1 | 115106:signal-handler (1600183259) Received SIGTERM scheduling shutdown…
20:20:59 redis_cache.1 | 115099:signal-handler (1600183259) Received SIGTERM scheduling shutdown…
20:20:59 system | worker_short.1 stopped (rc=-15)
20:20:59 system | worker_long.1 stopped (rc=-15)
20:20:59 system | worker_default.1 stopped (rc=-15)
20:20:59 system | socketio.1 stopped (rc=-15)
20:20:59 system | schedule.1 stopped (rc=-15)
20:20:59 redis_cache.1 | 115099:M 15 Sep 2020 20:20:59.603 # User requested shutdown…
20:20:59 redis_cache.1 | 115099:M 15 Sep 2020 20:20:59.603 * Removing the pid file.
20:20:59 redis_cache.1 | 115099:M 15 Sep 2020 20:20:59.603 # Redis is now ready to exit, bye bye…
20:20:59 redis_socketio.1 | 115103:M 15 Sep 2020 20:20:59.604 # User requested shutdown…
20:20:59 system | redis_cache.1 stopped (rc=-15)
20:20:59 redis_socketio.1 | 115103:M 15 Sep 2020 20:20:59.604 * Removing the pid file.
20:20:59 redis_socketio.1 | 115103:M 15 Sep 2020 20:20:59.604 # Redis is now ready to exit, bye bye…
20:20:59 system | redis_socketio.1 stopped (rc=-15)
20:20:59 redis_queue.1 | 115106:M 15 Sep 2020 20:20:59.608 # User requested shutdown…
20:20:59 redis_queue.1 | 115106:M 15 Sep 2020 20:20:59.608 * Removing the pid file.
20:20:59 redis_queue.1 | 115106:M 15 Sep 2020 20:20:59.608 # Redis is now ready to exit, bye bye…
20:20:59 system | redis_queue.1 stopped (rc=-15)
20:20:59 system | web.1 stopped (rc=-15)

Hope this will help.

@Suresh_Thakor
these commands shows nothing.

@Suresh_Thakor
I am getting this error while using this command
unix:///var/run/supervisor.sock no such file

No need to bench start.

sudo bench setup production [username]

Access your site on port 80 default.

@Suresh_Thakor
I am getting this while running your mentioned command
WARN: superuser privileges required for this command

bench command is not necessary for running this?

Everything depends on bench.

You should run bench command from bench folder i.e.
frappe@localhost:~/ frappe-bench $ sudo bench setup production

Is there bench-repo available?
If not then try.
sudo pip install -e bench-repo

@sohailamar i think restarting your server will fix this problem

Your listeners are on port 8001, 9001 etc (normally these are 8000,9000 etc)

This implies that there is already a running bench, which needs to be stopped/killed - and the try to run bench start again

Hi
open your terminal
go to your bench folder
run These Commands on your terminal

    sudo lsof -t -i tcp:8001 -s tcp:listen | sudo xargs kill
    sudo lsof -t -i tcp:11001 -s tcp:listen | sudo xargs kill
    sudo lsof -t -i tcp:12001 -s tcp:listen | sudo xargs kill
    sudo lsof -t -i tcp:13001 -s tcp:listen | sudo xargs kill
    bench start

@all
Thankyou all of you for your help.
I have installed frappe multiple time in multiple folders, I just deleted all of them restarted my Laptop and bench start works smoothly now.