Try ERPNext Buy Support Partners Foundation

Unable to Install ERPNext 12 (Easy Install Script)

Well, turns out I was wrong. Back to square one.
Will try to read and analyze your reply once more.
Guess I didn’t read/interpret it correctly

Hi,
Relevant part before the error after following what you said:
ansible-playbook 2.8.5
config file = None
configured module search path = [’/root/.ansible/plugins/modules’, ‘/usr/share/ansible/plugins/modules’]
ansible python module location = /usr/local/lib/python3.5/dist-packages/ansible
executable location = /usr/local/bin/ansible-playbook
python version = 3.5.2 (default, Oct 8 2019, 13:06:37) [GCC 5.4.0 20160609]
No config file found; using defaults

I now get the new error:
ERROR! the playbook: site.yml could not be found

Getting closer :wink:

Make sure you are in the correct directory.

This is where I see the site.yml on my system

  $ ls -l
    drwxr-xr-x 11 erpnext erpnext 4096 Oct 12 07:38 bench-repo
    drwxr-xr-x  7 erpnext erpnext 4096 Oct 12 07:41 frappe-bench
  $ find . -name "site.yml" -print
    ./bench-repo/playbooks/site.yml

configured module search path = [’/root/.ansible/plugins/modules’, ‘/usr/share/ansible/plugins/modules’]
implies that the ownership is by user=root, so probably a permissions error

Unfortunately I do not have a directory “bench-repo”
I would think it gets created after the point where I am facing failure

Running the commands as root - so shouldn’t be an issue

I am not sure which installation instructions your are following.

If you ignore the server requirements installation, installing the bench repository should be the first step in installing erpnext

$ sudo pip install -e bench-repo
$ bench init --frappe-branch version-12 --python /usr/bin/python2.7 frappe-bench
$ cd frappe-bench

I would suggest restarting your installation. There are a number of resources. I have linked to one that has a lot of useful info to assist you. I have not personally used that guide, but it is a handy reference.

Hi,
I was following the official Easy Install Guide/Script at:

If you want the list of commands I followed to reach the error:
apt-get update && apt-get upgrade -y
apt-get install python-minimal build-essential python-setuptools -y
adduser frappe
usermod -aG sudo frappe
cd /home/frappe
wget https://raw.githubusercontent.com/frappe/bench/master/playbooks/install.py
sudo python install.py --production --user frappe

As for the guide you referred to, I tried following that as well, but in vain

How did you prepare your system? What are you locale settings? On which OS under which parameters are you installing? There are many parameters. Did you disable IPv6? Do you have a firewall? Did you enable sudo for frappe user?

I haven’t done anything in particular to prepare it

Default settings on a DigitalOcean/Vultr server

Tried both Ubuntu 18.04 and 16.04. Not sure what you mean by parameters.

Not specifically, no.

Nope

Yes, using usermod -aG sudo frappe

What is the machine config ram disk space etc.? Did you apt update and apt upgrade before installing? Did you install the prerequisite packages before running easy install? I think you need some pro help out there.

1 vCore CPU VPS, 1GB RAM, 25 GB SSD - the basic cheap VPS

Yes, using
apt-get update && apt-get upgrade -y
apt-get install python-minimal build-essential python-setuptools -y

I do, good sir

You cannot install on a 1GB ram machine to my knowledge. What are your locale settings?

Get your hands on a virtual machine environment and start with 4gb ram. 2gb is a limit. you need to hack into the install process.

As per my knowledge, ERPNext requires >=1GB of RAM

How do I check that?

Currently doing that haha. The Easy Install Script isn’t getting me anywhere so I’m headed for a full blown manual install

Due to some stupid rule that a new user can’t post more than 6 replies in a day, I can’t add an additional response. However, I’m going to put down my next response as an edit to this one for the benefit of all:

I was able to get an instance up and running manually, with a lot of research, modifications and troubleshooting.
The two resources which helped me the most are:
https://discuss.erpnext.com/t/how-to-install-erpnext-from-a-z/54744
and
https://murgatroyd.za.net/?p=764

I did have to improvise and modify a lot of things, so I will be making a detailed guide for those who feel trapped, like I did,

I will also leave this thread open anyway, since the Easy Install Script still won’t work.

I have a manual install sequence that has worked 100% for me. The link is here

1 Like

I would like that a lot …

Why do I get a distinct feeling that you’re using DigitalOcean droplets? If so, we are in the same boat (pun intended). I guess since you’re a new user on the forum, you won’t get to reply on my post until tomorrow perhaps (because of that anti-spam/anti-bot stupid rule). I’m working on the same issue as I type, so I would try the 2 links you have mentioned, although I too had to improvise a lot, just like you. I will share my notes here, so that you may be able to compare them.

But one thing is for sure, the easy install scripts are buggy all of a sudden, and the manual install guides and the other articles are now outdated.

Cheers and best of luck!!

try contabo

it’s cheap and reliable.

I have no issue on installing erpnext there.

Hello sebinmichael,

how dich you solved your problem?

Did you have read this thread:

@ Sanath_Udayawansa2

https://contabo.com/

Why did you prefer contabo?
Which tutorial did you use to install ERPNext?

https://contabo.com/?show=tutorials

They doesn’t have a tutorial for ERPNext install.

jannis

There are not tutorial on most of the VPS. You need to follow the script. VPS only provide the service, they dont know what you are installing and its not their responsibility to give instructions of specific software.

FYI on Contabo purchase the Black coloured VPS (4 shown on right side of screen). These are pure SSD server with Intel Xeon processor and option of creating snapshots. The grey coloured servers are HDD running on Intel i7. These work fine but are slower than Xeon ones.

1 Like