Unable to get installation to work

Hi,

I followed the instructions on the https://github.com/frappe/bench page, using the "easy" option, and installed under a new user I created called "frappe" who I also added to my sudoers list.

I've followed this through to the production system and have configured Supervisor and NginX as per the instructions, however I get a 404 error when I try to view the website.

I had previously confirmed the NginX installation by checking that I could get the welcome page.

I'm running Ubuntu 14.04 with the latest version of MySQL, and ensured that I installed the other pre-reqs such as MariaDB.

Any help would be greatly appreciated.



Note:

 

If you are posting an issue,

 

  1. ERPNext is a free and open source software and support is given on this forum by a team (https://frappe.io/webnotes). So please consider donating if you find this forum useful (https://frappe.io/buy). Even a small amount would be helpful.
  2. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
  3. Paste your code at http://pastebin.com or http://gist.github.com and send only the URL via email
  4. For sending images, use http://imgur.com or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.

     

    End of Note



    You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

    To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un…@googlegroups.com.

    To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/fa15750c-7594-456f-a1b6-b6b85256d0df%40googlegroups.com.

    For more options, visit https://groups.google.com/d/optout.

On Tue, Aug 12, 2014 at 7:56 PM, Eve Scientist lo...@allumis.co.uk wrote:

Hi,

I followed the instructions on the https://github.com/frappe/bench page,
using the “easy” option, and installed under a new user I created called
“frappe” who I also added to my sudoers list.

I’ve followed this through to the production system and have configured
Supervisor and NginX as per the instructions, however I get a 404 error when
I try to view the website.

I had previously confirmed the NginX installation by checking that I could
get the welcome page.

I’m running Ubuntu 14.04 with the latest version of MySQL, and ensured that
I installed the other pre-reqs such as MariaDB.

Any help would be greatly appreciated.

Hi,

Did you create a new site? If so, then maybe the defaut site is not set,

can you run the command,

bench set-default-site {site-name}

(replace {site-name} with your site)

Thanks,

Pratik
erpnext