ERPNext Foundation ERPNext Cloud User Manual Blog Discuss Frappé* Donate

Unable to close financial year correct V10.1.77


#1

I’m facing the following issue.

I’ve closed the financial year 2018 (1-1-2018 - 31-12-2018 by using a Period Closing Voucher,
When i look at the ledger for this Period Closing Voucher I see that it seems to work correctly. Alls P&L accounts are debited en credited to a balance value of 0 for each account, the total balance value of all accounts combined is credited against the “capital” account (equity), this amount is the same as the total profit for 2018.
So far it seems to work.

When opening the balance for 2019 the capital account shows the correct amount but the rapport states that there is a ‘Unclosed Fiscal Years Profit / Loss (Credit)’ with an amount I don’t recognize. It also shows the “Previous Financial Year is not closed” message at the bottom.

When opening a Trail balance for 2019 and checking the “Show unclosed fiscal year’s P&L balances” checkbox it shows an opening value for all P&L accounts that have been balanced out by the Period Closing Voucher.
I don’t know if this correct behaviour as don’t really understand what the “Show unclosed fiscal year’s P&L balances” and “Period Closing Entry” checkbox do.

The Profit and Loss Statement for 2019 seems correct

I’ve read all related topics I could find but I’m still in the dark. Can someone help me out with this?


#2

Nobody has any idea how to solve this?


#3

Hi @Bas_de_Reus1,

Could this be linked to this issue ?

i.e can you post your chart of accounts root structure to see if it can be the source of the issue ?


#4

@chdecultot

Thank you for your reply.

You can download an export from my COA here: COA XLS file


#5

Hi @Bas_de_Reus1,

After a quick look it seems to be the same issue.
You have several root accounts for Liability, Expense and Asset and the opening balance is not calculated correctly with this configuration currently.
I guess you’ll have to wait for a correction…