Ubuntu 22.04 frappe/erpnext v13 Install

Kindly advise on the below shown issue occurred while running bench init

warning " > bootstrap@4.5.0" has unmet peer dependency "popper.js@^1.16.0".
warning Workspaces can only be enabled in private projects.

no sites were created yet.

The rest of bench build have no errors,

$ bench build
Retrieving assets...

✔ Downloaded Frappe assets from https://github.com/frappe/frappe/releases/download/v13.32.0/assets.tar.gz

Extracting assets...

✔ Restored js/user_profile_controller.min.js
✔ Restored js/bootstrap-4-web.min.js
✔ Restored js/bootstrap-4-web.min.js.map
✔ Restored js/dialog.min.js.map
✔ Restored js/checkout.min.js.map
✔ Restored js/frappe-web.min.js
✔ Restored js/checkout.min.js
✔ Restored js/moment-bundle.min.js
✔ Restored js/frappe-web.min.js.map
✔ Restored js/frappe-recorder.min.js.map
✔ Restored js/web_form.min.js
✔ Restored js/list.min.js.map
✔ Restored js/barcode_scanner.min.js.map
✔ Restored js/report.min.js.map
✔ Restored js/user_profile_controller.min.js.map
✔ Restored js/form.min.js
✔ Restored js/form.min.js.map
✔ Restored js/data_import_tools.min.js
✔ Restored js/control.min.js
✔ Restored js/report.min.js
✔ Restored js/list.min.js
✔ Restored js/dialog.min.js
✔ Restored js/web_form.min.js.map
✔ Restored js/data_import_tools.min.js.map
✔ Restored js/desk.min.js
✔ Restored js/control.min.js.map
✔ Restored js/barcode_scanner.min.js
✔ Restored js/libs.min.js
✔ Restored js/frappe-recorder.min.js
✔ Restored js/desk.min.js.map
✔ Restored css/printview.css
✔ Restored css/rollup.manifest.css
✔ Restored css/frappe-web-b4.css
✔ Restored css/email.css
✔ Restored css/web_form.css
✔ Restored css/login.css
✔ Restored css/desk.min.css
✔ Restored css/report.min.css
✔ Restored css-rtl/printview.css
✔ Restored css-rtl/frappe-web-b4.css
✔ Restored css-rtl/email.css
✔ Restored css-rtl/web_form.css
✔ Restored css-rtl/login.css
✔ Restored css-rtl/desk.min.css
✔ Restored css-rtl/report.min.css
✔ Application Assets Linked                                                                                             

yarn run v1.22.19
$ FRAPPE_ENV=production node rollup/build.js --skip_frappe
Production mode
✔ Built js/moment-bundle.min.js
✔ Built js/libs.min.js
Done in 0.52s.
SUCCESS: Bench /home/frappe/frappe-bench initialized

I don’t think that is “fatal error”.

I think in v14 the warning is fixed.

1 Like