Ubuntu 14.04 Install fails

Whats odd is using the exact same VPS setup yesterday it worked fine.

Vanilla Ubuntu 14.04

Both the script:
sudo bash setup_frappe.sh --setup-production
and command:
bench init frappe-bench && cd frappe-bench

= result in the same error:


Already using interpreter /usr/bin/python
100% |################################| 81kB 598kB/s
Cloning into ‘frappe’…
remote: Counting objects: 62667, done.
remote: Compressing objects: 100% (7/7), done.
remote: Total 62667 (delta 1), reused 0 (delta 0)
Receiving objects: 100% (62667/62667), 26.14 MiB | 8.52 MiB/s, done.
Resolving deltas: 100% (44453/44453), done.
Checking connectivity… done.
installing frappe
Traceback (most recent call last):
File “/home/admin/frappe-bench/env/bin/frappe”, line 5, in
from pkg_resources import load_entry_point
File “/home/admin/frappe-bench/env/local/lib/python2.7/site-packages/pkg_resources.py”, line 2951, in
working_set = WorkingSet.build_master()
File “/home/admin/frappe-bench/env/local/lib/python2.7/site-packages/pkg_resources.py”, line 563, in build_master
return cls._build_from_requirements(__requires)
File “/home/admin/frappe-bench/env/local/lib/python2.7/site-packages/pkg_resources.py”, line 576, in build_from_requirements
dists = ws.resolve(reqs, Environment())
File “/home/admin/frappe-bench/env/local/lib/python2.7/site-packages/pkg_resources.py”, line 761, in resolve
raise VersionConflict(tmpl % args)
pkg_resources.VersionConflict: pytz 2013d is installed but pytz>=0a is required by [‘babel’]
Error: None
Traceback (most recent call last):
File “/usr/local/bin/bench”, line 9, in
load_entry_point(‘bench==0.1’, ‘console_scripts’, ‘bench’)()
File “/home/admin/bench-repo/bench/cli.py”, line 38, in cli
return bench()
File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 610, in _call
return self.main(args, *kwargs)
File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 590, in main
rv = self.invoke(ctx)
File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 936, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 782, in invoke
return ctx.invoke(self.callback, *ctx.params)
File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 416, in invoke
return callback(args, **kwargs)
File “/home/admin/bench-repo/bench/cli.py”, line 106, in init
no_auto_update=no_auto_update, frappe_path=frappe_path, frappe_branch=frappe_branch)
File “/home/admin/bench-repo/bench/utils.py”, line 49, in init
get_app(‘frappe’, frappe_path, branch=frappe_branch, bench=path)
File “/home/admin/bench-repo/bench/app.py”, line 46, in get_app
build_assets(bench=bench)
File “/home/admin/bench-repo/bench/utils.py”, line 94, in build_assets
exec_cmd("{frappe} --build".format(frappe=get_frappe(bench=bench)), cwd=os.path.join(bench, ‘sites’))
File “/home/admin/bench-repo/bench/utils.py”, line 61, in exec_cmd
subprocess.check_call(cmd, cwd=cwd, shell=True)
File “/usr/lib/python2.7/subprocess.py”, line 540, in check_call
raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command ‘/home/admin/frappe-bench/env/bin/frappe --build’ returned non-zero exit status 1


I ran:

sudo easy_install --upgrade pytz

= result:


Searching for pytz
Reading https://pypi.python.org/simple/pytz/
Best match: pytz 2014.10
Downloading https://pypi.python.org/packages/2.7/p/pytz/pytz-2014.10-py2.7.egg#md5=a6e26cf01e307d3505612d7386fee859
Processing pytz-2014.10-py2.7.egg
Removing /usr/local/lib/python2.7/dist-packages/pytz-2014.10-py2.7.egg
Moving pytz-2014.10-py2.7.egg to /usr/local/lib/python2.7/dist-packages
pytz 2014.10 is already the active version in easy-install.pth

Installed /usr/local/lib/python2.7/dist-packages/pytz-2014.10-py2.7.egg
Processing dependencies for pytz
Finished processing dependencies for pytz


Removed frappe-bench directory and reran install script and got same error:

~
pkg_resources.VersionConflict: pytz 2013d is installed but pytz>=0a is required by [‘babel’]
~

same on vanilla centos7 minimal install

$ sudo easy_install --upgrade pytz
[sudo] password for frappe:
Searching for pytz
Reading https://pypi.python.org/simple/pytz/
Best match: pytz 2014.10
Downloading https://pypi.python.org/packages/2.7/p/pytz/pytz-2014.10-py2.7.egg#md5=a6e26cf01e307d3505612d7386fee859
Processing pytz-2014.10-py2.7.egg
Removing /usr/lib/python2.7/site-packages/pytz-2014.10-py2.7.egg
Moving pytz-2014.10-py2.7.egg to /usr/lib/python2.7/site-packages
pytz 2014.10 is already the active version in easy-install.pth

Installed /usr/lib/python2.7/site-packages/pytz-2014.10-py2.7.egg
Processing dependencies for pytz
Finished processing dependencies for pytz

$ /home/frappe/frappe-bench/env/bin/frappe --build
Traceback (most recent call last):
  File "/home/frappe/frappe-bench/env/bin/frappe", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/home/frappe/frappe-bench/env/lib/python2.7/site-packages/pkg_resources.py", line 2951, in <module>
    working_set = WorkingSet._build_master()
  File "/home/frappe/frappe-bench/env/lib/python2.7/site-packages/pkg_resources.py", line 563, in _build_master
    return cls._build_from_requirements(__requires__)
  File "/home/frappe/frappe-bench/env/lib/python2.7/site-packages/pkg_resources.py", line 576, in _build_from_requirements
    dists = ws.resolve(reqs, Environment())
  File "/home/frappe/frappe-bench/env/lib/python2.7/site-packages/pkg_resources.py", line 761, in resolve
    raise VersionConflict(tmpl % args)
pkg_resources.VersionConflict: pytz 2013d is installed but pytz>=0a is required by ['babel']
1 Like

Seems like there is a version conflict in the requirements. @pdvyas will fix this in a couple of hours or so.

1 Like

Thanks, I thought I was going nuts :wink: