Trying to install

Hi all,
I spent 15 hours to install erpnext in development mode but with no luck.

I try it on to Ubuntu 12.04. I installed all previous package before install Python 2.7.6 but when I install erpnext I receive that werkzeug.local does not exist. I installed werkzeug.local and then I receive another error.
I tried  on Centos 6.5 and nothing it's nothing seems to manual. A lot of errors.

Could someone share a  virtualbox image in development mode?

Thank,
Catalin



Note:

 

If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.

     

    End of Note



    You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

    To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un…@googlegroups.com.

    To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/867ffcb4-4220-41e7-9534-e4f8ba82e5fd%40googlegroups.com.

    For more options, visit https://groups.google.com/groups/opt_out.
Catalin, if you have a virtualbox image, you can enable the development adding `developer_mode = 1` inside conf.py in erpnext install dir,


2014-03-06 19:52 GMT-03:00 Catalin Lungu <ca...@gmail.com>:
Hi all,
I spent 15 hours to install erpnext in development mode but with no luck.

I try it on to Ubuntu 12.04. I installed all previous package before install Python 2.7.6 but when I install erpnext I receive that werkzeug.local does not exist. I installed werkzeug.local and then I receive another error.

I tried on Centos 6.5 and nothing it's nothing seems to manual. A lot of errors.

Could someone share a virtualbox image in development mode?

Thank,
Catalin



Note:



If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.



    End of Note



    You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

    To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un…@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/867ffcb4-4220-41e7-9534-e4f8ba82e5fd%40googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.




--

Best Regards.

Maxwell Morais
Python Developer powered by Webnotes framework <3
+55 11 954329659




Note:

 

If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.

     

    End of Note



    You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

    To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un…@googlegroups.com.

    To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/CABK1YkOb74qdb6W3wMoRQ3H4Yh4av8CmwBkXXBDGnnsurwGUTQ%40mail.gmail.com.

    For more options, visit https://groups.google.com/d/optout.

Hi Catalin,

On Fri, Mar 7, 2014 at 4:22 AM, Catalin Lungu ca...@gmail.com wrote:

Hi all,
I spent 15 hours to install erpnext in development mode but with no luck.

I try it on to Ubuntu 12.04. I installed all previous package before install
Python 2.7.6 but when I install erpnext I receive that werkzeug.local does
not exist.
Ubuntu 12.04 already ships with Python 2.7.(3).

Also, if you are planning to develop, start with Version 4. If you
start with a clean Ubuntu install,
https://github.com/frappe/frappe-bench/blob/master/Readme.md should
get ERPNext 4 up and running.

I installed werkzeug.local and then I receive another error.
I tried on Centos 6.5 and nothing it’s nothing seems to manual. A lot of
errors.

Could someone share a virtualbox image in development mode?

Thank,
Catalin


Note:

If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much
    information as you can. Please see it from the point of view of the person
    receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send
    only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do
    not send images as attachments. Links are good. Same goes for any file you
    are going to send.

End of Note

You received this message because you are subscribed to the Google Groups
“ERPNext Developer Forum” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to erpnext-developer-forum+un...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/erpnext-developer-forum/867ffcb4-4220-41e7-9534-e4f8ba82e5fd%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Thanks,

Pratik
erpnext

Hi Pratik,
Thanks for your help.

I've installed a clean Ubuntu 12.04.4
I've installed all prerequisites but the installation return me an error.
The virtualbox instance has 2048Mb.
What is the problem? Can you help me?

thanks,
Catalin



Note:

 

If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.

     

    End of Note



    You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

    To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un…@googlegroups.com.

    To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/ce62aaf5-3a7f-4fdb-a97f-95316bacf30c%40googlegroups.com.

    For more options, visit https://groups.google.com/d/optout.
I'm doing something wrong? What should I do to fix that?



Note:

 

If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.

     

    End of Note



    You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

    To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un…@googlegroups.com.

    To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/cd5a6e83-fbf2-46d7-8d8b-158df5de2765%40googlegroups.com.

    For more options, visit https://groups.google.com/d/optout.

Can you,
```
cd apps
../env/bin/pip install -e frappe/
```

So that we know what went wrong?

Will update the script to print the error, stupid mistake on my part.

sent from phone

On 8 Mar 2014 21:31, "Catalin Lungu" <ca...@gmail.com> wrote:
I'm doing something wrong? What should I do to fix that?



Note:



If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.



    End of Note



    You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

    To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un…@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/cd5a6e83-fbf2-46d7-8d8b-158df5de2765%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

Hi Catalin,

On Sat, Mar 8, 2014 at 9:31 PM, Catalin Lungu ca...@gmail.com wrote:

I’m doing something wrong? What should I do to fix that?

Did you install the pre requisites?
My guess it that it might have failed while installing lxml.


Pratik
erpnext

Hi Pratik,

I've installed all prerequisites one by one without any error. When you say lxml you mean liblxslt1.1 and libxslt-dev?
I've executed pip install -e frappe but no luck.


Thanks,
Catalin



Note:

 

If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.

     

    End of Note



    You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

    To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un…@googlegroups.com.

    To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/18c75be0-3736-4baa-801c-6ad38aeeb68a%40googlegroups.com.

    For more options, visit https://groups.google.com/d/optout.

Hi Catalin,

On Sun, Mar 9, 2014 at 2:56 PM, Catalin Lungu <ca...@gmail.com> wrote:

Hi Pratik,

I've installed all prerequisites one by one without any error. When you say lxml you mean liblxslt1.1 and libxslt-dev?

Yes
I've executed pip install -e frappe but no luck.
You've run the command from the bin directory not the app directory.

Anyways, I've updated the script to print the error if something goes wrong. From the bench directory, run `git pull` and try the install command again.

Also, please run install the bench as a non root user.



Thanks,
Catalin



Note:



If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.



    End of Note



    You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

    To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un…@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/18c75be0-3736-4baa-801c-6ad38aeeb68a%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.


Thanks,

--
Pratik
erpnext


Ok, here is the error. I executed
cd apps
../env/bin/pip install -e frappe/ from the application folder and the same error.

Thanks.



Note:

 

If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.

     

    End of Note



    You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

    To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un…@googlegroups.com.

    To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/ed367f17-ef60-48a7-b554-f43830b883c9%40googlegroups.com.

    For more options, visit https://groups.google.com/d/optout.

Hi Catalin

On Sun, Mar 9, 2014 at 11:44 PM, Catalin Lungu <ca...@gmail.com> wrote:


Ok, here is the error. I executed
cd apps
../env/bin/pip install -e frappe/ from the application folder and the same error.


apt-get install python-dev

Maybe it failed because your repos are not updated, do it with `apt-get update`

Also please use imgur to share images.

Thanks,

--
Pratik
erpnext
Hi Pratik,

I've updated the repository but the same result.
http://i.imgur.com/Lcd0ZHM.png

What's the next?

Thanks.



Note:

 

If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.

     

    End of Note



    You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

    To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un…@googlegroups.com.

    To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/aa31c254-234d-4f34-b763-08f0b0a4234d%40googlegroups.com.

    For more options, visit https://groups.google.com/d/optout.

Hi Catalin,

On Mon, Mar 10, 2014 at 12:10 AM, Catalin Lungu
ca...@gmail.com wrote:

Hi Pratik,

I’ve updated the repository but the same result.
http://i.imgur.com/Lcd0ZHM.png

Did you also install python-dev ?

What’s the next?

Thanks.


Note:

If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much
    information as you can. Please see it from the point of view of the person
    receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send
    only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do
    not send images as attachments. Links are good. Same goes for any file you
    are going to send.

End of Note

You received this message because you are subscribed to the Google Groups
“ERPNext Developer Forum” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to erpnext-developer-forum+un...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/erpnext-developer-forum/aa31c254-234d-4f34-b763-08f0b0a4234d%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Thanks,

Pratik
erpnext

Yes sir,
The installation process has finished ok. Which is the command to run erpnext?
Frappe framework has a gui interface?

What does this command?
./env/bin/honcho start



Note:

 

If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.

     

    End of Note



    You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

    To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un…@googlegroups.com.

    To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/04ff520d-012a-4a17-a2c9-adb04c8a5dca%40googlegroups.com.

    For more options, visit https://groups.google.com/d/optout.