Trying to install my Custom App fails in ERPNext14

I have installed ERPNext14 on local server and it is working properly.

I have a Custom App that I have developed in ERPNext13.

When I try to install this app in ERPNext14 the installation process fails.

Here is the output

bench install-app mymfg --force

Installing mymfg...
Updating DocTypes for mymfg         : [========================================] 100%
Updating customizations for Item Barcode
Updating customizations for Item
An error occurred while installing mymfg: Item: Options must be a valid DocType for field HSN/SAC in row 7
Traceback (most recent call last):
  File "apps/frappe/frappe/commands/site.py", line 413, in install_app
    _install_app(app, verbose=context.verbose, force=force)
  File "apps/frappe/frappe/installer.py", line 303, in install_app
    sync_customizations(name)
  File "apps/frappe/frappe/modules/utils.py", line 111, in sync_customizations
    sync_customizations_for_doctype(data, folder)
  File "apps/frappe/frappe/modules/utils.py", line 168, in sync_customizations_for_doctype
    validate_fields_for_doctype(doctype)
  File "apps/frappe/frappe/core/doctype/doctype/doctype.py", line 1036, in validate_fields_for_doctype
    validate_fields(meta)
  File "apps/frappe/frappe/core/doctype/doctype/doctype.py", line 1462, in validate_fields
    check_link_table_options(meta.get("name"), d)
  File "apps/frappe/frappe/core/doctype/doctype/doctype.py", line 1114, in check_link_table_options
    frappe.throw(
  File "apps/frappe/frappe/__init__.py", line 523, in throw
    msgprint(
  File "apps/frappe/frappe/__init__.py", line 491, in msgprint
    _raise_exception()
  File "apps/frappe/frappe/__init__.py", line 443, in _raise_exception
    raise raise_exception(msg)
frappe.core.doctype.doctype.doctype.WrongOptionsDoctypeLinkError: Item: Options must be a valid DocType for field HSN/SAC in row 7

How to resolve this problem?

Regards,

India Specific features have been moved to a separate app.

Therefore HSN/SAC Doctype is removed from ERPNext in version-14.

Solutions:

  1. You plan to use India Specific features โ†’ Install respective app.
  2. You do not plan to use India Specific features โ†’ Delete custom field gst_hsn_code from Item
  3. You need the field but not the app โ†’ edit custom field. set fieldtype to Data and remove GST HSN Code from options
2 Likes

Thanks for the update.

I am not able to find the separate app on git hub. I am referring to this url - Frappe ยท GitHub

Any ideas as to from where can I get this app for India specific features?

Regards,

Ok. I found the relevant Git link for installing India Compliance.

Regards,

3 Likes