Try ERPNext Buy Support Partners Foundation Foundation Members

That smtp username's account is not allowed to send

Hello,

While using frappe.sendmail(), got below error…

++++++++++++
(550, b"that smtp username’s account is not allowed to send")}
Traceback (most recent call last):
File “/home/frappe/frappe-bench/apps/frappe/frappe/email/queue.py”, line 425, in send_one
smtpserver.sess.sendmail(email.sender, recipient.recipient, encode(message))
File “/usr/lib/python3.5/smtplib.py”, line 876, in sendmail
raise SMTPRecipientsRefused(senderrs)
smtplib.SMTPRecipientsRefused: {‘xxxxx@gmail.com’: (550, b"that smtp username’s account is not allowed to send")}
++++++++++++

We’re using smtp2go smtp service providers…

Attached screenshots of Email Domain and notification set up…

+++
Email Domain setup

++++
Email Notification set up

what’s wrong here?

Thanks!

Port 25 is not recommended - rather use port 587 with TLS

@trentmu, changed the port…still getting same error…

@trentmu changed the port…still getting same error…

I am not sure why your settings aren’t working - maybe do what’s shown in this post…

This is kind of confusing. If you’re using smtp2go smtp service then why is your email address a gmail account? I presume every smtp service has a unique sender parameter which you must supply in order to connect to their smtp servers.

If on the other hand you are using a standard gmail account then you must observe gmail’s smtp configuration protocols and also, do not forget to enable access to less secure apps from your google account security page.

1 Like

Thanks…but if we are using smtp2go smtp services then from where I should set unique sender parameter ?

I think this is the answer you’re looking for:

Sending via SMTP
SMTP server: mail.smtp2go.com
SMTP port: 2525 (or 80, 25, 8025 or 587 if that doesn’t work).
Username / Password: Turn on SMTP authentication and enter your account’s SMTP username and SMTP password.
Note: TLS/SSL is optional. TLS is available on the same ports. SSL is available on ports 465 and 8465.

the SMTP username and password should be available in your smtp2go account. I can’t actually pry further as the service is not available in my country so it won’t allow me sign up so i can see the “insides” of an account.

1 Like

Thank you, now I am able to set those credentials…

1 Like