TASK [mariadb : Start and enable service] FAILED

TASK [mariadb : Start and enable service] **************************************************************************************************************************************
task path: /tmp/.bench/playbooks/roles/mariadb/tasks/main.yml:56
Running systemd
ESTABLISH LOCAL CONNECTION FOR USER: root
EXEC /bin/sh -c ‘echo ~root && sleep 0’
EXEC /bin/sh -c ‘( umask 77 && mkdir -p “echo /root/.ansible/tmp”&& mkdir /root/.ansible/tmp/ansible-tmp-1597786753.39-2197-16744446236643 && echo ansible-tmp-1597786753.39-2197-16744446236643="echo /root/.ansible/tmp/ansible-tmp-1597786753.39-2197-16744446236643" ) && sleep 0’
Using module file /usr/lib/python2.7/site-packages/ansible/modules/system/systemd.py
PUT /root/.ansible/tmp/ansible-local-17406GWOSM/tmp2kaaUP TO /root/.ansible/tmp/ansible-tmp-1597786753.39-2197-16744446236643/AnsiballZ_systemd.py
EXEC /bin/sh -c ‘chmod u+x /root/.ansible/tmp/ansible-tmp-1597786753.39-2197-16744446236643/ /root/.ansible/tmp/ansible-tmp-1597786753.39-2197-16744446236643/AnsiballZ_systemd.py && sleep 0’
EXEC /bin/sh -c ‘/usr/bin/python /root/.ansible/tmp/ansible-tmp-1597786753.39-2197-16744446236643/AnsiballZ_systemd.py && sleep 0’
EXEC /bin/sh -c ‘rm -f -r /root/.ansible/tmp/ansible-tmp-1597786753.39-2197-16744446236643/ > /dev/null 2>&1 && sleep 0’
fatal: [localhost]: FAILED! => {
“changed”: false,
“invocation”: {
“module_args”: {
“daemon_reexec”: false,
“daemon_reload”: false,
“enabled”: true,
“force”: null,
“masked”: null,
“name”: “mysql”,
“no_block”: false,
“scope”: null,
“state”: “started”,
“user”: null
}
},
“msg”: “Could not find the requested service mysql: host”
}

Looks like you’re running this as root - which is not advisable

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.